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Safety information

Important information

Read these instructions carefully and look at the equipment to become familiar with
the device before trying to install, operate, service or maintain it. The following spe-
cial messages may appear throughout this bulletin or on the equipment to warn of
potential hazards or to call attention to information that clarifies or simplifies a pro-
cedure.

The addition of either symbol to a "Danger" or "Warning" safety label indicates
that an electrical hazard exists which will result in personal injury if the instruc-
tions are not followed.

This is the safety alert symbol. It is used to alert you to potential personal injury
hazards. Obey all safety messages that follow this symbol to avoid possible
injury or death.

DANGER
DANGER indicates an imminently hazardous situation which, if not avoided,
will result in death or serious injury.

WARNING
WARNING indicates a potentially hazardous situation which, if not avoided,
could result in death or serious injury.

CAUTION
CAUTION indicates a potentially hazardous situation which, if not avoided,
could result in minor or moderate injury.

NOTICE
NOTICE is used to address practices not related to physical injury. The
safety alert symbol shall not be used with this signal word.

Please note
Electrical equipment should be installed, operated, serviced and maintained only by qualified personnel.
No responsibility is assumed by Schneider Electric for any consequences arising out of the use of this
material.

A qualified person is one who has skills and knowledge related to the construction, installation, and oper-
ation of electrical equipment and has received safety training to recognize and avoid the hazards involved.



Safety precautions
During installation or use of this software, pay attention to all safety messages
that occur in the software and that are included in the documentation. The
following safety message:

WARNING

UNINTENDED EQUIPMENT OPERATION

• Do not use the software for critical control or protection applications
where human or equipment safety relies on the operation of the control
action.

• Do not use the software to control time-critical functions because com-
munication delays can occur between the time a control is initiated and
when that action is applied.

• Do not use the software to control remote equipment without securing it
with an authorized access level, and without including a status object to
provide feedback about the status of the control operation.

Failure to follow these instructions can result in death or serious injury.

WARNING

INACCURATE DATA RESULTS

• Do not incorrectly configure the software, as this can lead to inaccurate
reports and/or data results.

• Do not base your maintenance or service actions solely on messages
and information displayed by the software.

• Do not rely solely on software messages and reports to determine if the
system is functioning correctly or meeting all applicable standards and
requirements.

• Consider the implications of unanticipated transmission delays or fail-
ures of communications links.

Failure to follow these instructions can result in death, serious injury,
equipment damage, or permanent loss of data.
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Introduction
The PowerSCADA Expert 8.1 with Advanced Reporting and Dashboards System
Development Guide describes the procedures involved in planning the
PowerSCADA Expert 8.1 with Advanced Reports and Dashboards project, installing
software, and creating a working system. When you have finished with the system
development process, you should have a fully installed operating system that includes:

• PowerSCADA Expert 8.1 and Power Monitoring Expert installed on separate
servers

• Citect as a service: allows you to install a remote Citect application that can then
access running Citect clients. You can view and control the client through a secure
web browser, which means you do not have to install Citect on portable devices.

• redundant servers: When you use a network, you can configure redundant I/O
devices to minimize the potential for data loss (in case a server should become
inoperative). You designate a Disk I/O device on both the primary and secondary
servers; Data is written to both Disk I/O devices. Thus, if the primary server
becomes inoperative, the standby server can be activated without interruption.

• scaled systems: Scaling provides the ability grow your system as large as it needs
to be to meet all of your monitoring needs.

• communication with devices
• alarms and trends
• Extract Transform Load (ETL): allows you to extract data from PowerSCADA Expert

and transform it into a format that loads into Power Monitoring Expert. From there, it
can be used for reports and dashboards.

You will install Power Monitoring Expert on a separate server

Assumptions
The PowerSCADA Expert 8.1 with Advanced Reporting and Dashboards System
Development Guide is intended for application engineers, system integrators, and
other qualified personnel that understand and have experience with power monitoring
systems. Qualified personnel will:

• have received Citect SCADA training
• understand how to install the various devices used in the project, and how to install

the PowerSCADA Expert 8.1 with Advanced Reports and Dashboards software
• have completed necessary reading and will have made decisions regarding

architecture and hardware specifications

Use this guide as a reference as you prepare and develop the PowerSCADA Expert
8.1 with Advanced Reports and Dashboards project that you are installing. For related
information, or where more detail is required, references are made to existing
documentation.

The PowerSCADA Expert 8.1 with Advanced Reporting and Dashboards is a power
management system that combines PowerSCADA Expert with the Advanced Reporting
and Dashboards features of Power Monitoring Expert. The installed system is made up
of hardware, software, and communication components. All of the elements are
modular and operate with each other to provide the information that the customer
needs to view data and interact with system features.

This document assumes that the system will include:
• PowerSCADA Expert 8.1 with Advanced Reports and Dashboards
• Event Notification Module (ENM)
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• Extract, Transform, Load module (ETL)
• PowerSCADA Anywhere (also referred to as CitectSCADA Anywhere)

Although this manual walks you through the development of a "typical" installation,
PowerSCADA Expert 8.1 with Advanced Reports and Dashboards provides the ability
to create very complex systems with many options. For example, you may want to
include redundant servers, or you may choose to not install ENM or ETL.

Prerequisites
Review the system development process provided in this document.

Gather the supporting documents that you may need. A list of related documents is
provided below.

Create a system architecture drawing, including the servers, devices and all
connectivity. Define the IP addressing for each gateway and device.

Order the appropriate equipment, including computers, software, and system devices.
For help in determining what you need for your system, see the PowerSCADA Expert
8.1 with Advanced Reports and Dashboards Design Guide.

Ensure that all devices that will communicate through this system are set up and
properly addressed.

Have a copy of the Example.CSV file for adding devices to the system. You will use this
file if you need to manually add multiple devices at a time to your project.

Set up the server and client computers that you need for your system.

Ensure that the IT team has opened the appropriate firewall ports.See the
PowerSCADA Expert 8.1 with Advanced Reports and Dashboards IT Infrastructure
Preparation User Guide for details.

Ensure that all license keys have been purchased and are ready to be installed.

Supporting Documentation
The following documents provide additional information that you may need to create
and run your system.
• citectscada.chm (Citect help file)
• Vijeo Citect 2015 Web Client Guide
• PowerSCADA Expert 8.1 with Advanced Reporting and Dashboards Design Guide
• StruxureWare PowerSCADA Expert 8.1 Installation Guide
• StruxureWare PowerSCADA Expert 8.1 with Advamced Reporting and Dashboards

ETL Administration Guide (7EN42-0117-00)
• PowerSCADA Expert 8.1 with Advanced Reports and DashboardsSystem

Integrator's Manual
• PowerSCADA Expert 8.1 with Advanced Reports and Dashboards IT Guide
• Event Notification Module lnstallation Guide, Version 8.3.1
• PowerSCADA Anywhere Server Installation and Configuration Guide
• PowerSCADA Anywhere Web Client User Guide
• PowerSCADA Anywhere Quick Start Guide
• IT Infrastructure Preparation for StruxureWare Power Monitoring Expert 8.1

Installation (locate this document on The Exchange)
• StruxureWare Power Monitoring Expert 8.1 Installation Guide
• (McAfee) Advanced-Parameter-EmbeddedControl-v6
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• (McAfee) Installation-Guide--v6.2.0
• (McAfee) Command Line Interface Guide
• McAfee-Embedded-Control-Code-Signing-Giodev1/2
• (McAfee) Product-Guide-v6.2.0
• (Tofino) ConneXium TCSEFEA Installation Manual V1
• (Tofino) ConneXium TCSEFEA User Manual V1

Server Preparation
You need to install PowerSCADA Expert for Advanced Reporting Module on a
separate server.

For details about server requirements and preparation, see the PowerSCADA Expert
Design Guide.
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Architecture
The architecture intended in the following engineering procedures combines
PowerSCADA Expert with the following add-on modules:

• Advanced Reporting and Dashboards
• Event Notification
• PowerSCADA Anywhere (or you can, as an alternative, use the PowerSCADA

Expert web client)
• McAfee Application Control

Also included as an optional step is to deploy Tofino industrial network firewalls in the
topology.

While not every customer solution will include this architecture in its entirety, it is
representative of the primary features, scaling, redundancy, and deployment
capabilities of PowerSCADA Expert and its add-on modules. The architecture diagram
below depicts the nominal scaled, redundant PowerSCADA Expert architecture.

Some customer solutions may require no redundancy. Some may require only a single
I/O server. Alternatively, some customer solutions may require more than 1 or 2
redundant I/O server pairs. The engineering procedure that follows in this manual will
apply to all of these scenarios by simply replicating or omitting the steps in the
procedure.

Other important aspects of this architecture are:

• Historical data logged by PowerSCADA Expert is transferred to the Advanced
Reporting and Dashboards server using the ETL tool. ETL is configured to transfer
data every 15 minutes between the primary PowerSCADA Expert server and the
Advanced Reporting server.

• PowerSCADA Anywhere is installed on a separate server, rather than on either
PowerSCADA Expert or the Advanced Reporting and Dashboards server. This is a
security consideration, limiting remote PowerSCADA Anywhere clients access to
just a remote PowerSCADA Expert thick control client rather than to the
PowerSCADA Expert server.

Tofino Firewalls. An optional network security improvement to this architecture can be
implemented with Tofino Network firewalls, as illustrated in the network topology
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diagram below. For details about this option, see Install and Configure the Tofino
Firewall on page 115.
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Software Installation
This section provides an overview of the general steps required to install:

• PowerSCADA Expert
• Event Notification Module (ENM): Use this module to set up notification of critical

power incidents. You set up ENM to monitor and receive alarm and event
information, and you designate users who will receive notification when defined
events occur.

• Extract, Transform, and Load (ETL): Use this module to extract historical data from
PowerSCADA Expert and transform it into a format that can be used in the
Advanced Reporting and Dashboards module.

• Advanced Reporting Module files: Advanced Reporting and Dashboards
• PowerSCADA Anywhere
• McAfee Application Control

Before you begin, you need:

• the PowerSCADA Expert server; see requirements in the PowerSCADA Expert 8.1
with Advanced Reports and Dashboards Design Guide.

• installation medium for PowerSCADA Expert 8.1 with Advanced Reports and
Dashboardsand PowerSCADA Expert 8.1 with Advanced Reports and Dashboards
Installation Guide

• installation medium for ENM, ETL and PowerSCADA Anywhere (included on the
PowerSCADA Expert 8.1 with Advanced Reports and Dashboards ISO)

• installation medium for .NET Framework 4.6, downloaded from Microsoft
• installation for SQL (SQL Express is included on the PowerSCADA Expert 8.1 with

Advanced Reports and Dashboards ISO,, but SQL Server must be obtained from
Microsoft.

On the PowerSCADA Expert Server Computers
The following table lists software that you will install on each of the servers and clients
in your project.

PowerSCADA
Primary Server

PowerSCADA
Secondary Server

PowerSCADA
Anywhere

Advanced Reporting
and Dashboards Server

PowerSCADAExpert 8.1 PowerSCADAExpert 8.1
PowerSCADA Expert 8.1
control client only

SQL Server

ETL ENM PowerSCADA Anywhere
Advanced Reporting and
Dashboards (from the
PowerSCADA Expert ISO)

ENM SQL Express
Windows Terminal Services
must be enabled.

SQL Express

PowerSCADA Expert Installation
On the server that you will use for PowerSCADA Expert, install software in the order
shown below. Follow the instructions to install PowerSCADA Expert in the Installation
Guide.

• If you are installing on a Windows 8 operating system, install all operating system
updates before you install PowerSCADA Expert.
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• Ensure that you have the correct Internet Explorer version for your operating
system. The PowerSCADA Expert Installation Guide provides this information.

• Install .NET 4.6.
• Install ENM.
• Install SQL Express.
• If you want to have Matrikon Explorer on the computer, install Matrikon before you

install PowerSCADA Expert.
• Install PowerSCADA Expert
• On the PowerSCADA Expert primary server computer only, install ETL.

On the PowerSCADA Anywhere Server Computers
The PowerSCADA Anywhere product enables you to remotely access a running
PowerSCADA Expert client with mobile devices, such as tablets, smartphones, and
laptop computers. You can view and control the client through a secure web browser,
but you do not need to install PowerSCADA Expert on your portable device.

You need to install PowerSCADA Anywhere on a remote client computer. See Install
and Configure the PowerSCADA Expert Secondary Server on page 99 for directions.

On the Advanced Reporting Module Computer
NOTE: The installation medium is located on the same DVD or .ISO as the
PowerSCADA Expert installation, in the Advanced Reporting Module folder.

On the server that you will use for the Advanced Reporting and Dashboards Module,
install software in the order shown below. Follow the instructions to install
PowerSCADA Expert in the Installation Guide.
• SQL: You must install SQL Server on the Advanced Reporting and Dashboards

server. Refer to the Power Monitoring Expert installation documentation for
information.

• Advanced Reporting Module: Use the PowerSCADA Expert 8.1 with Advanced
Reports and Dashboards installation medium and installation guide.
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Add a Project to Citect
In this section, you create a project file in Citect.

1. Launch Citect Explorer.
2. From the Citect Explorer window, click File > New Project. Type the project. name.

You will use this same name when you are importing project information from the
Profile Editor.

3. Uncheck the check box next to Create project based on starter project.
4. Add at least one cluster. A cluster is a means of organizing system servers. From

the Citect Project Editor window, click Servers > Clusters. Type a unique cluster
name. Click Add then close the window.

5. Create two network addresses, one for the primary server computer and one for the
secondary (standby) server: From the Citect Project Editor window, click Servers
> Network Addresses. Do not use the loopback address. Type a unique name for
the computer, and type its IP address. Click Add then close the window.

6. From the Citect Project Editor, create the remaining servers, using the following
procedure:
— IO server: exchanges data between I/O devices and clients. Data is not

processed, but is collected and passed to clients for display or to another server
for further processing. For heavy data traffic, multiple I/O servers will balance the
load.

— Alarm server: responsible for evaluating the conditions that define an alarm. It
evaluates notifications received from the I/O server. If notification of an alarm
condition is received, the alarm server generates an alarm.

— Trend: controls the accumulation and logging of tend data. Data provides a
current and historical view of the project, and it can be processed for use in
reports and graphics pages.

— Report: controls report processing

For each server, make sure you link it to the correct cluster and network address.

For instructions on creating graphics pages, seeCreate the Operator HMI on page 40.

Add Redundant I/O Alarm, Report, and Trend Servers
Follow these steps to add redundant I/O server pairs, redundant alarm servers, report
servers, and trend servers, as indicated in Architecture on page 9.

From the Citect Explorer screen, display the project: In the upper left corner of the
screen, choose the project from the drop-down menu.

Still on the Citect Explorer screen, click Servers > Network Addresses.

Add Alarm Servers
1. To add redundant alarm servers, click Servers > Alarm Servers.

2. At the Alarm Servers screen:
— At the Cluster Name screen, choose the cluster you will use for this server.
— At the Network Addresses field, choose the network name that you added for

the primary PowerSCADA Expert server network address..
— In the Mode field, specify whether this server is primary or standby. The standby

server acts as a backup, providing redundancy in case the primary server goes
down.

— Leave the Port field blank.
— In the Extended Memory drop-down box, choose True to have the alarm server

operate in extended memory mode (64 bit).
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— Click Add to save the new alarm server.
3. Repeat step 4 o create the redundant standby alarm server, setting the Mode field

to 'Standby' and choosing the Network Address earlier created for the secondary
PowerSCADA Expert server machine. Click Add to save the redundant server.

4. Browse to the alarm server definition that was automatically added by the Default_
Starter project.

5. Set "Extended Memory" mode to TRUE

6. Click Replace to commit your change.

7. Exit the window.

Add the I/O Servers

1. Click Servers > I/O Servers.
2. Set the I/O server name.

3. Select the Cluster Name.

4. Change port to any available Windows port number.

5. Select the Network Address earlier created for the primary PowerSCADA Expert
server.

6. Click Add.

7. Change the name to indicate a second primary I/O server, such as IOserver2_P.

8. Change port to any available Windows port number, not already used in your I/O
Server definitions.

9. Click Add. You should now have two I/O servers defined on the same Network
Address. This network address should be that of the machine designated as the
primary PowerSCADA Expert Server.

10. Modify the server name to indicate the first of two standby I/O servers, such as
IOServer1_S..

11. Choose the network address earlier created to represent the secondar
PowerSCADA Expert server machine.

12. Change port to any available Windows port number, not already used in your I/O
Server definitions

13. Click Add.

14. Modify the server name to indicate the second of two standby I/O servers, such as
IOServer2_S.

15. Choose the network address earlier created to represent the secondar PSE server
machine.

16. Change port to any available Windows port number, not already used in your I/O
Server definitions

17. Click Add.

You should now have four I/O servers definied in the project: two on the primary server
Network Address and two on the standby server Network Address.

Create the Redundant Trend Servers

1. Click Servers > Trend Servers.
2. Set the trend server name.

3. Select the Cluster Name.

4. Select the Network Address earlier created for the primary PowerSCADA server.

5. Click Add.
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6. Modify the name of the trend server to indicate the redundant standby server.

7. Choose the network address earlier created to represent the secondar PSE server
machine.

8. Click Add.

You should now havetwo trend servers defined in the project: one on the primary
server Network Address and one on the standby server Network

Create the Redundant Report Server

Repeat the steps for redundant trend servers, but instead select Servers > Report Serv-
ers from the Citect Project Editor menus.

NOTE: When you delete a cluster, you must also click File > Pack to completely delete
it from the system.

9. Click File > Compile.

10. If there are errors and/or warnings after the page is compiled:

a. At each error, click GoTo, which opens the location where the error has
occurred.

b. Using the information in the error message, correct the error.
c. After all errors are addressed, re-compile to verify that the errors are removed.

For additional information, click Help at the error screen.

Add Redundant NetworkTagsDev and zOL Devices
1. Click Tools > I/O Device Manage
2. Select "Create an I/O Device in the project."

3. Choose "Cluster Setup" under System Devices.

4. Accept the default device/equipment names.

5. Check "Supports Redundancy."

6. Set the primary server to one of the 4 available I/O servers.

7. Set the standby server to one of the 2 I/O servers on a different network address.

8. Allow to finish and select "Add/update/remove more devices."

9. Select "Create an I/O Device in the project."

10. Choose "OneLine Device Setup" from System Devices.

11. Accept the default device/equipment names.

12. Finish and close the I/O Device Manager Wizard.

Configure PowerSCADA Expert to Run As a Service
Running PowerSCADA Expert as a Windows service protects applications that provide
runtime and historical data to clients . For these applications, a service interruption
cannot be tolerated. Normally, an application that only supports stand-alone program
operation is forced to shut down when a log out occurs on the host machine; but
running PowerSCADA Expert as a service allows data to be preserved across user log
in sessions.

This means that PowerSCADA Expert can run unattended, with no user account
required to log in to the server. The application can also be started automatically at
system power on, minimizing downtime in the event of a system reboot or unexpected
issue. Security benefits, as well as efficiency improvements, are gained when users do
not have to log in to the operating system. Access to the server can be restricted and
locked down to suit specific security requirements.
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In summary, the main benefits to run as a Windows service are:

• efficient use of resources
• increased security
• high availability
• true client/server architecture

Configuration
When you install PowerSCADA Expert 8.1, a service is automatically created. By
default, the service ‘Status’ is stopped, the ‘Startup Type’ is set to Manual and the ‘Log
On As’ is set to the Local System account:

You may need to configure dependencies with another service. In the following
example, the FlexNet Licensing Service is used for product licensing, so it needs to be
the first service that is started. The Citect Runtime Manager will have a dependency on
the FlexNet Licensing Service to acquire a valid license.

You can use the Service Controller configuration command (sc config) to modify the
service entries in the registry and in the Service Control Manager settings.

To configure the required dependency using the Service Controller configuration
command, first launch a command prompt with Administrator privilege. Then, enter the
following command to create a dependency of the FlexNet License Service service to
start before the Citect Runtime Manager service:

sc config “Citect Runtime Manager” depend= “FlexNet Licensing
Service”

NOTE:You must insert a space character after the depend= parameter. You must also
enclose any service names in quotes, which includes spaces in their names.
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Windows Service Operation
With the Citect Runtime Manager now configured, note the following:

• The service is run as Local System account on Session 0.
• When an application is run in Session 0, it is not possible to raise this session to the

active desktop to interact with it. It will remain hidden.

In order to launch PowerSCADA Expert at Windows startup, make sure that the
“Startup Type” is set to “Automatic,” then reboot the machine to allow PowerSCADA
Expert to run as a Windows service. Alternatively, you can right click the ‘Citect
Runtime Manager’ service, and select ‘Start’ to run PowerSCADA Expert without
rebooting the machine.

You can now log in and log off without disrupting the system.
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Compile the Project
After you install the software and create the project—along with clusters, network
addresses, and servers—perform your first system compile. You will also do this
periodically during system setup.

It is always a good idea to "pack" before you compile. From the Citect Project Editor,
click File > Pack. Then, from the Citect Project Editor, click File > Compile. Correct any
errors and note any warnings.
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Create Device Profiles and Tags
Using the Profile Editor, you create devices and tags that you can import into the final
project

Using the tabs in the Profile Editor, complete these steps:

• add device types and related tags
• create device profiles and link tags
• set up onboard alarms and waveforms.
• create a project for the tags
• export the project and tags to be used in the Citect project

NOTE: For complete instructions on the use of each field in these screens, click the
help link (?) at the top of the page. The help file will open to instructions for the screen
you are viewing.

Add Device Types and Tags
Follow this procedure to add a device type and tags for the device.

Open the Profile Editor and click the Define Device Type Tags tab.

Review Default Device Types and Tags
PowerSCADA Expert includes, by default, a large number of device types and their
associated tags. . Before you create custom device types, review the following
information. The device types and tags that you want may already be created for you..

To view the device types and tags, follow these steps:

1. Open the Profile Editor. Either click the icon on your desktop, or click Start > All
Programs > Schneider Electric > PowerSCADA Expert 8.1 > Config Tools > Profile
Editor.

2. On the Define Device Type Tags tab, select a device type name from the Device
Type Name drop-down list.

The available tags display in the body of the page. There are several subtabs for
real-time tags, onboard alarms, control tags, and reset tags. The tags that are
selected for the device type display there.

Don't Find What You Need?
If you do not find the device type or tags that you need, you can do one of the following:

• Create Custom Device Types on page 22
• Create Custom Tags on page 19

Create Custom Tags
A custom tag is a unique measurement that is assigned to a device type, or is an
existing tag for which the tag address is changed.

From the Add/Edit Device Type tab, click Add/Edit Custom Tags. Enter the information
for the new tag.

On the Add / Edit Custom Tags screen, click the help link (?) at the top right of the
screen. The help that displays leads you through adding, editing, or deleting custom
tags
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NOTE: To avoid potential communication errors, you should use the Profile Editor to
create all custom tags that will communicate with equipment.

Click these links to learn about adding custom tags:

Set Up Custom Tags on page 20

Edit Generic Tag Addresses on page 22

Set Up Custom Tags
Use the Add/Edit Custom Tags screen to edit the information about a custom tag. To
view this screen, click Add/Edit Custom Tags at the bottom of the Add/Edit Device Type
screen; or, from the upper left of the Profile Editor screen, click Settings > Set Up
Custom Tags. The Add/Edit Custom Tags screen displays. The following table
describes the fields.

Instructions for editing or deleting a custom tag are after the table.

Field Name Valid Entries Comments

Custom TagOptions

Create New Click to begin adding a new tag.

Create From
Click to begin adding a new tag that is based on an
existing custom tag. For example, youmight want to
changemetadata for another custom tag.

Edit Existing Click to edit the attributes of an existing tag.

Delete Existing
Click to delete a tag (tag cannot be associated with a
device type).

Tag to Create From

Tag to Edit

Tag to Delete

From the drop-downmenu, select the tag you want to
create from, edit or delete.

Delete button
Live only when Delete Existing is selected. Click to
delete the tag. You can only delete custom tags not
associated with a device type.

Display Associated
Device Types

Click to display device
types that are
associated with this tag.

Live only when in Edit mode. Click to list device types
that are associated with this custom tag. Note the
device types so that you can delete the tag from them (in
the Add/Edit Device Type screen) before you delete the
tag.

SeeDelete a Custom Tag on page 22 for instructions on
using this button.

Tag Name

Type the new tag name;
or type the changed
name for a tag you are
editing.

Maximum 32 characters; can include any alpha or
numeric character, as well underscore (_) and backslash
(\). Must begin with either an alpha character of
underscore.

Display Name

Type the name that you
want to display when
selecting the tag and in
other displays.

Youmight use this field for additional information on the
Add/Edit Custom Tags screen. For example, you could
describe the data that it logs. It does not display
anywhere else in the system.

Group Select the group.
Includes all of the real-time groups (such as 100ms,
controls, currents) plus onboard alarms, resets, and
controls.

Data Type Select the data type.

These are PowerSCADAExpert tag data types. They
affect the logic codes that are available for display in the
Edit Address screen. See Logic Codes for the data type
that matches each logic code.
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Field Name Valid Entries Comments

Eng. Units Select the base unit.
These are the base engineering units for tags, from
Engineering Unit Setup.

Ignore Unit Conversion

Check to cause the
system to ignore any
conversions that were
added for this tag.

Causes reporting to be according to the base unit, rather
than the conversion that was chosen for this tag in the
template that is being used.

Add Eng Unit

Click to open the
Add/Edit Units screen,
to add a new engineering
unit and/or conversion.

Provides a quicker means of adding an engineering unit
that had been overlooked.

Citect Format
Select the numerical
format.

This is used for display purposes in PowerSCADA
Expert graphics pages. It determines where the decimal
displays.

Choose the reporting format, to be used in PowerSCADA
Expert, from ## to #0.#####. For example, if you select
#.##, the number 8.12579 would be displayed as 8.12.

Polling Priority Low, Normal, or High

Indicates the level of priority PowerSCADAExpert uses
when reading data from devices.

Note: In the address field, a priority of 1 =High, 2 =
Medium,
3 = Low.

Alarm On Text
For onboard alarms only:
enter the text for when
the alarm is On.

This text displays on the Create Device Profiles tab for
the onboard alarm tag, when it is selected for the device
type in the profile. It also displays in the Alarm Log.

Alarm Off Text
For onboard alarms only:
enter the text for when
the alarm is Off.

Display ‘Advanced’ filter
selections

Check to display
additional filter options in
the Real Time Filter and
Alarm Filter tabs

Displays several additional filter options on the two
“Filter” tabs. These options will be useful in the future for
reporting purposes.

You can include additional filters for either real time filters or alarm filters. Though not currently used, these filters
will providemetadata for later reporting. Standard tags have some of these filters selected.

A typical usage for these filters might be: when creating a custom tag from an already existing standard tag, you
can creatematchingmetadata by using the filters that have been built in to the standard tag.

Real Time Filters tab (dropdown lists are expanded when “Display ‘Advanced’ filter selections” is
checked)

Category Type
Select a category for this
tag.

This field provides metadata about the tag. It will be used
in future reports.

Utility Type Select a utility type. Metadata for future use in reporting.

Statistical Type Select a statistical type. Metadata for future use in statistical reporting.

Quantity Select a quantity. Metadata for future use in statistical reporting.

Alarm Filters tab (dropdown lists are expanded when “Display ‘Advanced’ filter selections” is
checked)

Categorization
Select the alarm
category

Used for filtering and sorting alarm data. Alsometadata
for future use in statistical reporting.

Alarm Type Select the alarm type.
Used for filtering and sorting alarm data. Alsometadata
for future use in statistical reporting.
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Field Name Valid Entries Comments

Alarm Group Select the group.
Used for filtering and sorting alarm data. Alsometadata
for future use in statistical reporting.

Subcategorization Select a subcategory.
Used for filtering and sorting alarm data. Alsometadata
for future use in statistical reporting.

Alarm Level
Select the severity level
of the alarm.

Used for filtering and sorting alarm data. Alsometadata
for future use in statistical reporting.

Edit a Custom Tag

You can edit any custom tag. To edit a tag:

1. Open the Add/Edit Custom Tags screen (from the Add/Edit Device Type screen,
click Add/Edit Custom Tags).

2. In the Custom Tag Options box, click Edit Existing.

3. You can change any of the tag attributes. (This does not change the tag’s
assignment status; if it is selected for a device type, it does not move back to the
IEC Tags list.)

4. Click Save to save changes, or click Save & Exit to save changes and close the
screen.

Delete a Custom Tag

You can delete any custom tag that is not associated with a device type.

If the tag is associated with a device type, you must first deselect the tag:

1. Change the option to Edit Existing and display the tag you want to delete.
2. Click Display Associated Device Types to display all device types that include this

tag. Make a note of the device types.

3. Return to the Add/Edit Device Type screen. For each device type listed, deselect
the tag that you want to delete.

Continue deleting the tag:

1. Open the Add/Edit Custom Tags screen.
2. In the Custom Tag Options box, click Delete Existing.

3. From the drop-down menu, choose the tag you want to delete.

4. Click Delete. At the Confirm prompt, click Yes.

5. Click Save to save the change, or click Save & Exit to save changes and close the
screen.

Edit Generic Tag Addresses
This screen displays when you click Edit for an address of a non-PowerLogic
compatible device type, such IEC 61850 or DNP3.

The variable tag properties used in this screen are described in a topic in the Citect
help file. For detailed information, see Variable Tag Properties in the
citectSCADA.chm help file (Program Files> Schneider Electric > PowerSCADA Expert
> v8.1 > bin).

Create Custom Device Types
A custom device type is any device type that is not included in the standard set of
devices. Typically, this is a third-party device type that communicates through a
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protocol such as IEC 61850 or DNP3. Each protocol requires a slightly different
process.

The help file describes the process for each of these protocols:

• IEC 61850
• Modbus third party
• DNP3
• composite device type

To begin creating a new custom device type, open the Profile Editor.

From the Define Device Type Tags tab, click Add/Edit to display the Add/Edit Device
Type window. Complete the information on the screen, following instructions in the
help file for the protocol the device uses.

Create Device Profiles
After device types are added to the project, use the Create Device Profiles screens to
view and edit profiles for individual devices. Because profiles are defined for the
standard devices, use this feature to add third-party device profiles. On these screens,
you can make changes to a standard device type, and then save the device as a profile
that is included in your project. You can:

• override tag names
• select tags to be included in PC-based alarms and trends

Enable Waveforms for Onboard Alarms
To enable waveforms, making them available for viewing in the runtime environment,
follow these steps:

1. At the device, or via the meter configuration software (PMCU), add the alarm and
enable the automatic capture of a waveform when the alarm occurs.

2. In the Profile Editor, on the Create Device Profiles tab, for the same alarm you
added in PMCU, check the Waveform box.

When this alarm occurs at the device, the waveform will be captured. The files will
be transmitted to PowerSCADA Expert and will be available for viewing. The
amount of time this takes depends on the number of I/O servers you have and the
number of serial devices on a chain. On a very large system with numerous serial
devices, this could take as much as an hour.

You can view the waveform from the Alarm Log in the runtime environment.

Add an Onboard Alarm Tag
When a device onboard alarm has not been included in PowerSCADA Expert, you can
add it from the Profile Editor. You need to follow these steps to include the device’s
unique identifier. Otherwise, the alarm will not annunciate in the Graphics page.

You can only add onboard alarms for devices using the CM4, PM8, Micrologic, or
Sepam drivers. CM4, PM8, and Micrologic unique IDs must be decimal; SEPAM
unique IDs must be hexadecimal.

1. From the device, obtain the unique identifier for this alarm. Additionally, for
MicroLogic, you need to include the unique sub-identifier.

2. You also need the file number in which alarms on stored on the device.

3. From the Profile Editor, add the onboard alarm.
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Create and Export a Project
You create a project file to include the tags and devices you add in the Profile Editor.
The project file is then exported from the Profile Editor.

The project is exported to:

C:\ProgramData\Schneider Electric\PowerSCADA Expert\v8.1\Applications\Profile
Editor\WizardProfiles\"project name"\ProfileWizard

where "project name" is the name used when you created the project

An Export Summary screen displays with the results of the export.

After you export the profile, you will add the included I/O devices into your final project.
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Add I/O Devices to the Project
To begin, launch the I/O Device Manager from the Citect Project Editor (Tools > I/O
Device Manager). You see the I/O Device Manager window.

The first three options send you to a wizard that walks you through creating, removing,
or updating

Throughout the I/O Device Manager wizard, there are fields that will only accept a valid
entry. They are marked with a red asterisk (!). The asterisk remains there until you enter
a response that is of the correct length or includes only the acceptable characters. The
asterisk disappears when you have entered a valid response.

Click a link for what you want to do.

• Define One I/O Device in a Project on page 25
• Remove a Device From the Project on page 33
• Use a CSV File to Define Multiple Devices on page 34
• Update One or All Devices in Project on page 37

The following link provides additional information that you need to know.

Add Redundant NetworkTagsDev and zOL Devices on page 15

Before You Use the I/O Device Manager
Have a copy of each device’s connection information: communications protocol and IP
address. You will enter this information when you add the devices.

Define One I/O Device in a Project
Use the wizard in the I/O Device Manager to add one device at a time.

Throughout the I/O device wizard, there are fields that will only accept a valid entry.
They are marked with a red exclamation point (!). The exclamation point remains there
until you enter a response that is of the correct length or includes only the acceptable
characters. The exclamation point disappears when you have entered a valid
response.

For each device added using the I/O Device manager wizard, follow the same
redundancy steps outlined when earlier adding the NetworkTagsDev and zOL
redundant devices. Be sure to select a primary I/O server and a standby I/O server,
each from different network addresses.

For each device added using the I/O Device manager wizard follow the same
redundancy steps outlined in Add Redundant NetworkTagsDev and zOL Devices on
page 15. Be sure to select a primary I/O server and a standby I/O server, each from a
different Network Address.

Click one of these links to display instructions to add each type of protocol:

Add a TCP Device to a Project on page 26

Add a Serial Device to a Project on page 28

Add a DNP3 TCP Device on page 29

Add an IEC 61850 Device to a Project on page 31
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Add a TCP Device to a Project
Use this procedure when you want to add a generic TCP or Modbus TCP device to a
project. Note that these instructions assume that you have two I/O servers, and that you
will be renaming ports.

Before you begin, make sure that you have added at least one cluster and the
appropriate servers for this project (see Add Redundant I/O Alarm, Report, and Trend
Servers on page 13).

Then, make sure that you have set up each of these clusters in the I/O Device
Manager:

Cluster Setup: Before you add devices, you need to set up each cluster that was
created for the project (you must have added at least one cluster to PowerSCADA
Expert before you do this): 

1. From the I/O Device Manager, under System Devices, click Cluster Setup. Click
Next.

2. At the Enter Instance Information screen, a cluster name displays. Click Next.

3. If there are multiple clusters, the Select cluster screen displays. Choose the cluster
you want to set up. Click Next.

4. If there are multiple I/O servers in the cluster, the Select I/O servers screen displays.
Check Supports Redundancy and select the I/O servers to which you want to add
the device. Click Next.

5. At the Ready to perform action screen, click Next.

If you have more than one cluster to add, repeat steps 3 through 5 for each cluster.

When you are finished adding clusters and I/O servers, you return to the I/O Device
Manager welcome screen.

Add the TCP Device

Follow these steps to add TCP devices:

1. From the Citect Explorer screen, display the project to which you want to add the
devices: In the upper left corner of the screen, choose the project from the drop-
down menu.

2. From the Citect Project Editor, click Tools > I/O Device Manager.

The I/O Device Manager welcome screen displays.

3. Click Create an I/O Device in the project, then click Next.

4. At the Choose profile screen, select the first device profile that you want to use to
add a device to the project. Click Next.

NOTE: To ensure that the Alarm Log displays properly with the PM5000 series
devices, use the correct PM5000S or PM5000S1 driver for devices:

Use the PM5000S driver (for the most recent Alarm Log implementation) with:
— PM51XX
— PM53XX
— PM55XX
— PM5350PB
— PM5350IB with FW version 3.00 and higher

Use the PM5000S1 driver (for previous Alarm Log implementation) with:
— PM5350 with FW prior to version 3.00
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5. At the Enter instance information screen, type a descriptive profile name, for
example: CM4Bay1Circuit1 (no spaces or punctuation; to allow space in
PowerSCADA Expert, the preferred limit is 16 characters). The Comment field is
stored in the equipment.dbf file.

NOTE: There are several “description” or “comment” fields throughout the product.
These fields can be used to create copy for translation purposes. If you type a
Comment in this format:

@(XXX), where XXX = the copy that is to be translated,

the copy you typed in the comment field is added to the default language, named
English.DBF. After the project is compiled, this file is located in Documents and
Settings\All Users\Application Data\Schneider Electric\PowerSCADA Expert 8.0,
Servce Release 1\User\[your project]. English.dbf contains terms that will be
translated from English.

To create another language file for translation, set the Citect.ini parameter
[Language]LocalLanguage to the specified language, then re-compile. So, for
example, if you set this parameter to French, a French.dbf file is created in the
project folder when you compile. You can then enter the translated text in the
LOCAL field of the file. Repeat this same step for each additional language file you
want in this project.

At runtime, the user will be able to choose the .dbf file that is to be used in the
display, thus changing the language used in the display.

Click Next.

6. At the Select I/O servers screen, choose the primary and standby servers. You can
only set the standby server if you check the "Supports Redundancy" box. Click
Next.

7. If you choose to add an optional sub-profile: At the Configure Sub-Profile
Communications Method screen, choose the communications method used for the
first sub-profile in this project. Click Next.

8. At the Communications Settings screen, type the gateway address and station
address for each of the servers. If you check the "Same as Primary" box for standby,
you will use the same addresses for the primary and standby. Click Next.

9. At the Port Settings screen, you can rename each of the ports. A new port will be
generated for each new name. Click Next.

10. At the Ready to perform action screen, click Next.

After the devices are added, a screen displays telling you that the project was
updated successfully.

To view a detailed list of all of the device profiles and all operations performed in
the project, check the View audit log box. The list displays after the device is added.

To continue adding or removing device profiles, click Next. Repeat steps 3 through
8.

11. When you have finished adding devices, uncheck the Add/remove more equipment
option, then click Finish.

If you checked the View audit ... box, the list displays.

If you did not check the Add/remove... box, the I/O Device Manager closes. If you
checked the Add/remove ... box, the Welcome screen displays again.

12. From any of the three PowerSCADA Expert screens, compile the project.

13. When all errors are corrected, click File > Run to view the runtime environment.
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Add a Serial Device to a Project
Use this procedure when you want to add a generic serial or DNP3 via serial device to
a project. Note that these instructions assume that you have two I/O servers, and that
you will be renaming ports.

Before you begin, make sure that you have added at least one cluster and the
appropriate servers for this project (see Add Redundant I/O Alarm, Report, and Trend
Servers on page 13).

Then, make sure that you have set up each of these clusters in the I/O Device
Manager:

Cluster Setup: Before you add devices, you need to set up each cluster that was
created for the project (you must have added at least one cluster to PowerSCADA
Expert before you do this): 

1. From the I/O Device Manager, under System Devices, click Cluster Setup. Click
Next.

2. At the Enter Instance Information screen, a cluster name displays. Click Next.

3. If there are multiple clusters, the Select cluster screen displays. Choose the cluster
you want to set up. Click Next.

4. If there are multiple I/O servers in the cluster, the Select I/O servers screen displays.
Check Supports Redundancy and select the I/O servers to which you want to add
the device. Click Next.

5. At the Ready to perform action screen, click Next.

If you have more than one cluster to add, repeat steps 3 through 5 for each cluster.

When you are finished adding clusters and I/O servers, you return to the I/O Device
Manager welcome screen.

Add the Serial Device

Follow these steps to add serial devices.

1. From the Citect Explorer screen, display the project to which you want to add the
device: In the upper left corner of the screen, choose the project from the drop-
down menu.

2. From the Citect Project Editor, click Tools > I/O Device Manager.

The I/O Device Manager welcome screen displays.

Click Create an I/O Device in the project, then click Next.

3. At the Choose profile screen, select the first device profile that you want to use to
add a device to the project. Click Next.

4. At the Enter instance information screen, type a descriptive profile name, for
example: CM4Bay1Circuit1 (no spaces or punctuation; to allow space in
PowerSCADA Expert, the preferred limit is 16 characters). The Comment field is
stored in the equipment.dbf file.

NOTE: There are several “description” or “comment” fields throughout the product.
These fields can be used to create copy for translation purposes. If you type a
Comment in this format:

@(XXX), where XXX = the copy that is to be translated,

the copy you typed in the comment field is added to the default language, named
English.DBF. After the project is compiled, this file is located in Documents and
Settings\All Users\Application Data\Schneider Electric\PowerSCADA Expert 8.0,
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Servce Release 1\User\[your project]. English.dbf contains terms that will be
translated from English.

To create another language file for translation, set the Citect.ini parameter
[Language]LocalLanguage to the specified language, then re-compile. So, for
example, if you set this parameter to French, a French.dbf file is created in the
project folder when you compile. You can then enter the translated text in the
LOCAL field of the file. Repeat this same step for each additional language file you
want in this project.

At runtime, the user will be able to choose the .dbf file that is to be used in the
display, thus changing the language used in the display.

Click Next.

5. At the Select I/O servers screen, choose the primary and standby servers. You can
add information for the standby server if you check the "Supports Redundancy"
box. Click Next.

6. If you choose to add an optional sub-profile: At the Configure Sub-Profile
Communications Method screen, choose: At the Configure Sub-Profile
Communications Method screen, choose the communications method used for the
first sub-profile in this project. Click Next.

7. At the Communications Settings screen, type all of the information for each server
(com port, baud rate, and so on). If you check the "Same as Primary" box for
standby, you will use the same addresses for the primary and standby. Click Next.

8. At the Port Settings screen, you can rename each of the ports.

9. When you finish adding the last sub-profile, the Ready to perform action screen
displays Click Next.

After the devices are added, a screen displays telling you that the project was
updated successfully.

To view a detailed list of all of the device profiles and all operations performed in
the project, check the View audit log box. The list displays after the device is added.

To continue adding or removing device profiles, click Next. Repeat steps 3 through
8.

10. When you have finished adding devices, click Finish at the Project updated
successfully screen.

If you checked the View audit ... box, the list displays.

The I/O Device Manager closes.

11. From any of the three screens, compile the project.

12. When all errors are corrected, click File > Run to view the runtime environment.

Add a DNP3 TCP Device
Use this procedure when you want to add a DNP3 TCP device to a project. Note that
these instructions assume that you have two I/O servers, and that you will be renaming
ports.

Before you begin, make sure that you have added at least one cluster and the
appropriate servers for this project (see Add Redundant I/O Alarm, Report, and Trend
Servers on page 13).

Then, make sure that you have set up each of these clusters in the I/O Device
Manager:
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Cluster Setup: Before you add devices, you need to set up each cluster that was
created for the project (you must have added at least one cluster to PowerSCADA
Expert before you do this): 

1. From the I/O Device Manager, under System Devices, click Cluster Setup. Click
Next.

2. At the Enter Instance Information screen, a cluster name displays. Click Next.

3. If there are multiple clusters, the Select cluster screen displays. Choose the cluster
you want to set up. Click Next.

4. If there are multiple I/O servers in the cluster, the Select I/O servers screen displays.
Check Supports Redundancy and select the I/O servers to which you want to add
the device. Click Next.

5. At the Ready to perform action screen, click Next.

If you have more than one cluster to add, repeat steps 3 through 5 for each cluster.

When you are finished adding clusters and I/O servers, you return to the I/O Device
Manager welcome screen.

Add the DNP3-TCP Device

Follow these steps to add TCP devices:

1. From the Citect Explorer screen, display the project to which you want to add the
devices: In the upper left corner of the screen, choose the project from the drop-
down menu.

2. From the Citect Project Editor, click Tools > I/O Device Manager.

The I/O Device Manager welcome screen displays.

Click Create an I/O Device in the project, then click Next.

3. At the Choose profile screen, select the first device profile that you want to use to
add a device to the project. Click Next.

4. At the Enter instance information screen, type a descriptive profile name, for
example: CM4Bay1Circuit1 (no spaces or punctuation; to allow space in
PowerSCADA Expert, the preferred limit is 16 characters). The Comment field is
stored in the equipment.dbf file.

NOTE: There are several “description” or “comment” fields throughout the product.
These fields can be used to create copy for translation purposes. If you type a
Comment in this format:

@(XXX), where XXX = the copy that is to be translated,

the copy you typed in the comment field is added to the default language, named
English.DBF. After the project is compiled, this file is located in Documents and
Settings\All Users\Application Data\Schneider Electric\PowerSCADA Expert 8.0,
Servce Release 1\User\[your project]. English.dbf contains terms that will be
translated from English.

To create another language file for translation, set the Citect.ini parameter
[Language]LocalLanguage to the specified language, then re-compile. So, for
example, if you set this parameter to French, a French.dbf file is created in the
project folder when you compile. You can then enter the translated text in the
LOCAL field of the file. Repeat this same step for each additional language file you
want in this project.

At runtime, the user will be able to choose the .dbf file that is to be used in the
display, thus changing the language used in the display.

Click Next.

30 © 1990–2016 Schneider Electric All Rights Reserved

7EN02-0382-00 Add I/ODevices to the Project
03/2016



5. At the Select I/O servers screen, choose the primary and standby servers. You can
only set the standby server if you check the "Supports Redundancy" box. Click
Next.

6. If you choose to add an optional sub-profile: At the Configure Sub-Profile
Communications Method screen, choose: At the Configure Sub-Profile
Communications Method screen, choose the communications method used for the
first sub-profile in this project. Click Next.

7. At the Communications Settings screen, type the IP address, port number, and
device address for each of the servers.

NOTE: The DNP3 port number is by definition 20000. You must type 20000 here in
order for communications to work correctly.

If you check the "Same as Primary" box for standby, you will use the same
addresses for the primary and standby. Click Next.

8. At the Port Settings screen, you can rename each of the ports. A new port will be
generated for each new name. Click Next.

9. At the Ready to perform action screen, click Next.

After the devices are added, a screen displays telling you that the project was
updated successfully.

To view a detailed list of all of the device profiles and all operations performed in
the project, check the View audit log box. The list displays after the device is added.

To continue adding or removing device profiles, click Next. Repeat steps 3 through
8.

10. When you have finished adding devices, uncheck the Add/remove more equipment
option, then click Finish.

If you checked the View audit ... box, the list displays.

If you did not check the Add/remove... box, the I/O Device Manager closes. If you
checked the Add/remove ... box, the Welcome screen displays again.

11. From any of the three screens, compile the project.

12. When all errors are corrected, click File > Run to view the runtime environment.

Add an IEC 61850 Device to a Project
Use this procedure when you want to add an IEC 61850 device to a project. Note that
these instructions assume that you have two I/O servers, and that you will be renaming
ports.

There will be an additional .dbf file for each translated language. At runtime, the user
will be able to choose the .dbf file that they want to use in the display. This changes the
language in the display.

Before you begin, make sure that you have added at least one cluster and the
appropriate servers for this project (see Add Redundant I/O Alarm, Report, and Trend
Servers on page 13.

Then, make sure that you have set up each of these clusters in the I/O Device
Manager:

Cluster Setup: Before you add devices, you need to set up each cluster that was
created for the project (you must have added at least one cluster to PowerSCADA
Expert before you do this): 

1. From the I/O Device Manager, under System Devices, click Cluster Setup. Click
Next.
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2. At the Enter Instance Information screen, a cluster name displays. Click Next.

3. If there are multiple clusters, the Select cluster screen displays. Choose the cluster
you want to set up. Click Next.

4. If there are multiple I/O servers in the cluster, the Select I/O servers screen displays.
Check Supports Redundancy and select the I/O servers to which you want to add
the device. Click Next.

5. At the Ready to perform action screen, click Next.

If you have more than one cluster to add, repeat steps 3 through 5 for each cluster.

When you are finished adding clusters and I/O servers, you return to the I/O Device
Manager welcome screen.

Add the IEC 61850 Device
1. From the Citect Explorer screen, display the project to which you want to add the

devices: In the upper left corner of the screen, choose the project from the drop-
down menu.

2. From the Citect Project Editor, click Tools > I/O Device Manager.

The I/O Device Manager welcome screen displays.

Click Create an I/O Device in the project, then click Next.

3. At the Choose profile screen, select the first device profile that you want to use to
add a device to the project. Click Next.

4. At the Enter instance information screen, type a descriptive profile name, for
example: Bay1Circuit1 (no spaces or punctuation; to allow space in PowerSCADA
Expert, the preferred limit is 16 characters). The Comment field is stored in the
equipment.dbf file.

NOTE: There are several “description” or “comment” fields throughout the product.
These fields can be used to create copy for translation purposes. If you type a
Comment in this format:

@(XXX), where XXX = the copy that is to be translated,

the copy you typed in the comment field is added to the default language, named
English.DBF. After the project is compiled, this file is located in Documents and
Settings\All Users\Application Data\Schneider Electric\PowerSCADA Expert 8.0,
Servce Release 1\User\[your project]. English.dbf contains terms that will be
translated from English.

To create another language file for translation, set the Citect.ini parameter
[Language]LocalLanguage to the specified language, then re-compile. So, for
example, if you set this parameter to French, a French.dbf file is created in the
project folder when you compile. You can then enter the translated text in the
LOCAL field of the file. Repeat this same step for each additional language file you
want in this project.

At runtime, the user will be able to choose the .dbf file that is to be used in the
display, thus changing the language used in the display.

LDName
In the Additional Information section at the bottom, you can change the original
logical device names for the IED. This is required only if the logical device name
was changed in the SCL file that was imported into the Profile Editor.

BRCBs and URCBs
In the Additional Information, you can also enter BRCB or URCB information.
BRCBs (buffered report control blocks) and URCBs (unbuffered report control
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blocks) can be used to return data in blocks rather than in individual tags. To enter
either one, you need to have downloaded an SCL file for the device in question.
When you click the line to add data, you must browse to the SCL file and select the
BRCB/URCB you want. You will need the logical device, logical node, and RCB
names. The Help column gives examples of the formatting that is required.

Click Next.

5. At the Communications Settings screen, browse to the location where you have
saved the SCL file. If there is only one IED, it displays automatically; otherwise,
choose the correct device. Click Next.

6. At the Ready to perform action screen, click Next.

After the devices are added, a screen displays telling you that the project was
updated successfully.

To view a detailed list of all of the device profiles and all operations performed in
the project, check the View audit log box. The list displays after the device is added.

To continue adding or removing device profiles, click Next. Repeat steps 3 through
6.

7. When you have finished adding devices, uncheck the Add/remove more equipment
option, then click Finish.

If you checked the View audit ... box, the list displays.

If you did not check the Add/remove... box, the I/O Device Manager closes. If you
checked the Add/remove ... box, the Welcome screen displays again.

8. From any of the three screens, compile the project.

9. When all errors are corrected, click File > Run to view the runtime environment.

Remove a Device From the Project
1. From the Citect Explorer screen, display the project from which you want to remove

the device: In the upper left corner of the screen, choose the project from the drop-
down menu.

2. From the Citect Project Editor, click Tools > Profile Wizard.

The Profile Wizard welcome screen displays.

3. Click Remove a device from the project, then click Next.

4. At the Remove a device screen, click the dropdown menu to display the equipment
names that were used when the device profiles were added in the Profile Wizard.
From this list, select the device that you want to remove. Click Next.

5. At the Ready to perform action:

To compress the project files after removing this profile, click Pack databases.

Click Next.

After the device is deleted, a screen displays telling you that the project was
updated successfully.

To view a detailed list of devices that you have added or deleted, check the View
audit log box. The list will show all of the device data that has been added, as well
as the data that has been removed in this session. The list displays after you click
Finish.

6. To continue removing devices, check Add/remove more devices, then click Next.
Repeat steps 4 and 5.

7. When you have finished removing devices, uncheck Add/remove more devices,
then click Finish.
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If you checked the View audit ... box, the list displays.

If you did not check the Add/remove... box, the Profile Wizard closes. If you checked
the Add/remove... box, the Welcome screen displays again.

Use a CSV File to Define Multiple Devices
The I/O Device Manager makes it easy to create a PowerSCADA Expert project. Use
this tool to make either single or bulk additions, updates and deletions to the
PowerSCADA Expert device database.

Valid communication protocols are:

• DNP3 Serial
• DNP3 Ethernet
• Modbus/RTU Gateway
• Modbus TCP
• ION
• ION/Gateway
• IEC60870-5-104 TCP
• IEC61850

You first need to create the .CSV file that you will use to add the devices. For help, see:

Create a CSV File to Add Devices on page 34

After you create the .CSV file, you use it to add multiple devices to the project. See:

Add Multiple Devices to the Project on page 36

Create a CSV File to Add Devices
Follow these instructions to create a CSV file that you will use to add multiple devices
into the project. To view sample CSV files, see:

CSV File Samples on page 38

NOTE: You can edit the CSV file to remove unused columns, or to drag and drop
columns to position them where they are easy to read.

1. For an existing project: Before you begin, make a backup copy of your project.

For a new project: In the Citect Explorer, add a new project. From the Project Editor,
define a cluster; and add alarm, trend, and I/O servers (see Before You Use the I/O
Device Manager on page 25).

2. In the Profile Editor, create and export a project that includes the device types and
profiles included in this installation. Give the project the same name you used in
step 1. (See Create and Export a Project on page 24 for more information.

3. In Excel, Open Office, or other .CSV file editor, open the example CSV file for your
device type. The files are named "exampleXX," where XX is the device type, such
as ION or Modbus TCP. These files are located in the Windows Program Data file: 

Program Data > Schneider Electric\PowerSCADA Expert\c8.1\Examples.

4. In this sample CSV file, you will add the communications methods and the devices
that you want to add to the project.

NOTE: For sample CSV files, see CSV File Samples on page 38.

5. In the sample CSV worksheet, enter the following information for each device that
you want to add:
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a. ProfileName: the name of the profile that has been exported from the Profile
Editor into the target PowerSCADA Expert project. Type the names of the
profiles that have been selected for this project. To view names, open the Profile
Editor utility.

b. Name: Enter the device name, limit of 32 characters; include only letters,
numbers, and underscores (_). The first character cannot be a number or
underscore. This field becomes the "Name" on the I/O Devices screen and the
"I/O Device" name on the Equipment screen.

c. Cluster: The name of the cluster to which the device will be added.
d. Equip: Enter the equipment name, limit of 40 characters; include only letters,

numbers, and periods (.). The first character cannot be a number or period. This
field becomes the "Name" on the Equipment screen. You will use this when
adding genies to drawings.

e. CommsMethod: Type the communications protocol being used, e.g.,
MODBUS/RTU via Gateway. See list below for alternate communication
connections. When using a composite device, do not use this field. You must
enter a "SubProfile1Description" (and a "SubProfile2Description" for the second
part of the composite device).
DNP3 Serial
DNP3 TCP
Modbus/RTU via Gateway
Modbus/TCP
ION
ION/Ethergate
IEC60870-5-104 TCP
IEC61850 Native

f. Primary SclFileName: For IEC61850 Native, the address where the CID (SCL)
file is stored.

g. Primary IedName: For IEC61850 Native, the name of the IED in the CID file.
This was created when the profile was added in the Profile Editor.

h. FTPHost: For IEC61850 Native, the on-board FTP. Not currently used in
PowerSCADA Expert.

i. FTPUserName/Password: For IEC61850 Native, the username and password
for FTP on the device.

j. BRCBS/URCBS: For IEC61850 Native, buffered report control blocks (BRCBs)
and unbuffered report control blocks (URCBs) can be used to return data in
blocks, rather than in tags. These two fields provide the instruction used for
each. The two examples in the example are:
BRCB: CFG/LLN0$BR$BRep01,CFG/LLN0$BR$BRep06
and
URCB: CFG/LLN0$RP$URep02

k. Primary IO Server Name: The name of the primary server I/O server for the
device..

l. PrimaryIPAddress: Type the IP address for the the primary server (required only
for MODBUS/RTU and MODBUS/RTU via Gateway).

m. PrimaryEquipmentAddress: Type the device address (required only for
MODBUS/RTU and MODBUS/RTU via Gateway).

n. PrimaryPortNumber: Type the port number of the primary server (required only
for MODBUS/RTU and MODBUS/RTU via Gateway).
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o. PrimaryPortName: Type the port name of the primary server (required only for
MODBUS/RTU and MODBUS/RTU via Gateway).

p. Columns that begin with "SubProfile" followed by a number (e.g., SubProfile1,
SubProfile2, SubProfile3, etc.) are used to provide the same information as the
Primary and Standby columns for composite devices where each SubProfile is
a specific device which is part of the larger composite device.

q. Comment: This is an optional description of the device; maximum 254
characters.

6. Close the example CSV file, if it is open.

7. Go to Add Multiple Devices to the Project on page 36 to add the devices from this
.CSV file to your PowerSCADA Expert project.

Add Multiple Devices to the Project
To use this tool, you need to be on the same computer as the PowerSCADA Expert
server, and you must have created and exported your project from the Profile Editor.
You also need the .CSV file that you previously created (seeCreate a CSV File to Add
Devices on page 34). Do not have your project running in runtime. You will need
access to:

• the .ini file for your project
• the Equipment.Profile file for your project
• the CSV file from which you want to add/update/remove data

Status Options

In the upper right corner of the screen, you see the following:

• Display options: Click any of the boxes to cause the corresponding message types
(such as error and warning information) to display during and after the automation
process.

• Automation status: In blue copy, the most recent activity displays, such as
"Validation Complete: data is valid".

• Clear button: Click to clear the message lines from the right pane.

The Automation Process

To run batch changes related to a specific CSV file, follow these steps:

1. Launch the Manage I/O Devices tool (From the Citect Project Editor, click Tools
> Manage I/O Devices.

On the new screen, the Project Name field displays your project name. If there are
multiple projects, it displays the first one in alphabetic order.

2. Choose the correct project.

The Citect INI file and Equipment profile are automatically selected, based on the
project.

3. Input CSV defaults to the current directory. If you have stored the CSV elsewhere,
browse to where you have placed it.

4. Before you add, update, or remove devices and profiles, choose the action you
want to perform. To ensure that you will be successful, validate the action:

Action Description

Adding Devices Use to add devices that you have defined in the CSV file.
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Action Description

Removing
Devices

Use to remove devices from the project You only need the ProfileName and Equip columns
for this action.

Updating Devices

Use to update tag associations for a device if the device profile has changed. You only
need the ProfileName and Equip columns for this action. (Note: This action does not
update the IP address or other device information. If these attributes are not correct, you
need to remove, and then re-add, the device.).

Updating Profiles
Use to update the tag associations for all of the devices in the specified profile(s). You only
need the ProfileName and Equip columns for this action.

In this case, the option chosen is "Adding Devices."

5. Click Validate.

You see a screen like this:

On the new screen, in the right-hand pane, note that the data is valid.

If there are errors or warnings, they display in the Messages pane, and a specific
line number is indicated.

After you validate, you can perform the Add/Update/Remove action that you just
validated. The steps below illustrate adding.

6. Do not change the project name or file locations. Click the appropriate action (in
this case, Add Devices).

NOTE: Before any action is performed, a validate is performed. If issues are
detected, you will be prompted to choose whether you want to continue the action.
If you continue, lines with issues will not be processed.

After the action is processed, you see a screen that indicates that you successfully
added two devices.

If you are unable to validate or perform the desired action, read the right-hand pane.
Errors and warnings will help you troubleshoot the issue.

Launch PowerSCADA Expert and verify communication for all of the devices listed in
the spreadsheet.

Exporting CSV Files

If you want to export information from the project file (variable tags, clusters, and
equipment, for example), click Export at the bottom left part of the window. Choose the
location at which you want to store the files, and click OK.

Update One or All Devices in Project

Update a Profile and Add it Back to the Project
This feature works only if the device was added in version 7.20 or later. You cannot
update devices that were added in version 7.10.

After you have added devices to the project, and you make changes to the device in
the Profile Editor (e.g., add a large number of tags),you can use the I/O Device
Manager to bring the changes in the project.

NOTE: If you have made manual changes to the profile in PowerSCADA Expert
(Citect), do not use this process: you could corrupt your data. You must delete the
device from the project, re-export it from the Profile Editor, and add it back to Citect via
the I/O Device Manager.
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To use this method of importing changes:

1. Make the changes in the Profile Editor. Make sure you refresh the tags before you
continue.

2. Export the project from the Set Up Projects tab.

3. From the Citect Project Editor, click Tools > I/O Device Manager.

4. At the Welcome screen, check Update one or more I/O Device(s) in the project.
Click Next.

5. At the choose update type screen, check whether you want to update all instances
in a profile, or just one instance. Click Next.

6. Note the two possibilities:

a. If you selected all instances, choose the profile, and click Next.
b. If you selected "one instance," the Update profile instance screen displays.

From the drop down list, choose the instance you want to update.
7. At the Ready to perform action screen, note the instance(s) you are about to

update. If you want to change your choice, click Back.

To compress the project files in PowerSCADA Expert, check "Pack databases after
update."

When you have made the update choice you want, click Next.

When the update is finished, the Project updated successfully screen displays. You
can view an audit log of changes that have been made, process more changes, or
click Finish to leave the I/O Device Manager.

Edit a Device in PowerSCADA Expert Only
If, when you added the device to the project, you entered incorrect information (e.g.
wrong IP address), do the following:

1. Delete the device from the project: Use the “Remove a device from the project”
feature in the I/O Device Manager.

2. In the I/O Device Manager, add the device back to the project.

Add Device Data in PowerSCADA Expert Only
If you need to add a small amount of data to a device that is in the project (e.g., add a
single tag), add it directly in PowerSCADA Expert. Be sure that you also add it to the
device in the Profile Editor so that it is available for other devices in the future.

CSV File Samples
When you want to add multiple devices at a single time, you will create CSV files. The
following files are samples of files that may be used for some of the various
communication protocols.

For instructions on defining multiple devices, see Use a CSV File to Define Multiple
Devices on page 34.

DNP3 for Serial and Ethernet
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IEC104.2

IEC61850

Compile the Project
After you install the software and create the project—along with clusters, network
addresses, and servers—perform your first system compile. You will also do this
periodically during system setup.

It is always a good idea to "pack" before you compile. From the Citect Project Editor,
click File > Pack. Then, from the Citect Project Editor, click File > Compile. Correct any
errors and note any warnings.
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Create the Operator HMI
The human-machine interface( HMI)is the final view that users see. It includes various
pages, such as the alarm and event logs and one line displays. When you use the
Default_Starter template, some template pages are automatically created.

To customize the view, you can do the following:

Create a New Graphics Page on page 40

Enter Genie Properties on page 43

Create a One-Line Graphics Page on page 41

Create a New Graphics Page
There are two ways to create a graphics page. The recommended way is to use a
template; but you can choose to create the page.

Use a Template to Create a Graphics Page on page 40

After you create the graphics page, you need to compile it. You can run the page to
review its elements and correct any errors.

Use a Template to Create a Graphics Page
Follow these instructions to create a graphics page that is based on the default
template in PowerSCADA Expert.

1. In the Citect Graphics Builder, click File > New.
2. From the New window, click the top option, Page, which displays the Use Template

page:

3. Choose the Normal template (shown above).

Normal includes buttons for basic page control (such as alarms displays and menu
pages). There is a large open area to display one-line drawings.(See the table
below for a description of other templates that are provided in different styles.)

4. Select the pls_style_1 template from the Style list. It is the most feature-rich
template that is designed for the complex projects created in PowerSCADA Expert.

5. Select the screen resolution for the graphics page. We recommend that you use
SXGA, or at least 1024 x 768. Options are:
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Setting Resolution (height x width)

VGA 640 x 480

SVGA 800 x 600

XGA 1024 x 768

SXGA 1280 x 1024

WUXGA 1920 x 1200

User user-defined height and width

6. Check Linked to maintain the link for the graphics page with the original template.
Then, if you change the template, the page will reflect the change.

7. Check Designed for showing title bar if you want to display the graphics page with
the Windows title bar visible. The Windows title bar lets you maximize, minimize
and close the window.

8. Click OK.

9. Save the page (File > Save As): Type a name, to be used for the page in the
runtime view; and choose the project to which you want to add it. Click OK.

Later, when you need to access this page, open it from the File > Open option in the
Graphics Builder.

Create a One-Line Graphics Page
You will build a one-line by adding genies to the new page. To begin creating a one-
line, start adding genies to the page:

1. Click the “genie” icon on the toolbar:

2. From the Paste Genie screen, choose a library (to ensure that all PowerSCADA
Expert features are available, choose a library that begins with “pls”). If you want to
edit a genie or create a new one, see Enter Genie Properties on page 43 for
instructions.

3. From the available icons in the selected library, select a genie; click OK to paste the
genie on the graphics page.

4. A popup window displays for you to enter genie properties. Enter the requested
information for the appropriate object:
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Configure a Busbar on page 45

Configure a Circuit Breaker or Switch on page 44

Configure a Meter on page 43

Configure a Source on page 43

Configure a Transformer on page 44

NOTE: An asterisk in any of the windows indicates that it is a required field.
5. If a message displays telling you that variable tags are not found, and asking if you

want to add the unknown tags, this is not a problem. The genie is expecting to see
a variable, but one may not exist in the equipment (for example, it could be looking
for a “racked out” variable in a Sepam). Click No to this message.

NOTE: To disable this message, go to the Project Editor page. Click Tools >
Options. From the Options window, de-select “Prompt on tag not exist.”

The genie is added to the page.

6. Continue adding the genies to make up the graphics page.

After you create the graphics page, you need to compile it. You can run the page to
review its elements and correct any errors.

NOTE: Do not drag genies off of the page. They will disappear.
7. On the Graphics Page, click File > Compile.

While the page is being compiled, the Compiler displays each file name as it is
being compiled. A message then displays, telling you that compilation was
successful.

8. If there are errors and/or warnings after the page is compiled, a message box
displays, telling you the number of errors and warnings. You must understand all
warnings and correct all of the errors. To begin, do the following:

a. Click OK at the Compiler message.
The Compile Errors window displays the first error.

b. Note the error message. For more information on each error, click Help; note the
Description for that Error Message.

c. To correct the error, click the GoTo link.
The appropriate window displays for you to correct that error.

9. Correct each error. Warnings do not need to be corrected in order to run the project;
but they should be checked to see if they impact the project (such as a tag that is
not defined).

10. If you delete any entries, click File > Pack to clean up the files.

11. Re-compile and verify that all of the errors have been addressed.

NOTE: You can also view the Compile Errors window from the Project Editor (File >
Compile Errors).

12. After all errors are corrected, run the project (File > Run).

The Graphics page displays in the runtime environment. Note: Until you edit the
Menu Configuration file, only basic tabs will display on the Graphics page.

13. Before you can view your one-line, you need to edit the Menu Configuration file,
which controls the appearance of the graphics page in the runtime environment.
See Add Pages to Project Menu Configuration on page 61.
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Enter Genie Properties
As you create genies, you need to set various properties so that they communicate
properly on the one-line graphic. These properties include such information as its
label, type of equipment, how each genie communicates within the one-line, and
source and destination.

The following links provide information on how to configure the various genie types:

Configure a Meter on page 43

Configure a Source on page 43

Configure a Transformer on page 44

Configure a Circuit Breaker or Switch on page 44

Configure an Automatic Transfer Switch (ATS) on page 45

Configure a Busbar on page 45

Configure a Meter

Use this option to configure meters that you add to a one-line in the graphics builder.

1. Display the meter window by pasting the meter genie on to the graphics builder
page.

2. Equipment: From the drop-down list, choose the name of the equipment
represented by the genie (this is the equipment name that you entered in the
I/O Device Manager, e.g., CM4Main). To view the equipment that is available for
this page, you must have the project selected in the Citect Explorer.

3. Meter Number: Type the number you want to use for this meter (valid entries: 1–
1000). This number must be unique within this one-line.

4. Busbar Number: Type the number for the busbar that connects to the meter. Valid
entries: 1–1000.

5. Line Active: Enter the appropriate Cicode expression (such as MyTag1 > 0) to
determine when the meter detects power on the busbar.

6. Label 1 and Label 2: Type the information that you want to appear in the upper left
corner of the genie in the runtime environment.

7. Value Type: From the drop-down list, choose the tag you want to use for this genie.
The related information displays in the lower left corner of the genie in the runtime
environment.

This tag causes real-time data (such as currents) to display on the genie status
page in the runtime environment. If you do not choose a tag here, the status page
will not display the real-time data.

8. Units: From the drop-down list, choose the unit that you would like to display on the
genie in the runtime environment. Units that display here were added in the Profile
Editor.

9. Multiplier: Enter the multiplier that is to be applied to the units chosen in step 8.
10. Click OK to save the genie to the page and to return to the graphics builder page.

Configure a Source

Use this option to configure sources (e.g., utilities and generators) that you add to a
one-line in the graphics builder.
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1. Display the source window by pasting the generator or utility genie on to the
graphics builder page.

2. Source Number: Type the number you want to use for this source (valid entries: 1–
100). This number must be unique within this one-line.

The source number is used when you determine coloring for the one-line.

3. Busbar Number: Type the number for the busbar that connects to the source. Valid
entries: 1–1000.

4. Line Active: Enter the appropriate Cicode expression (such as MyTag1 > 0) to
dictate when the source powers the busbar.

5. Click OK to save the genie to the page and to return to the graphics builder page.

Configure a Transformer

Use this option to configure transformers that you add to a one-line in the graphics
builder.

1. Display the transformer window by pasting the appropriate genie on to the graphics
builder page.

2. Top and Bottom Source Number: For each source, whether top or bottom, type a
source number to control voltage-level coloring for the secondary side busbar.
Valid entries: 1–100.

There are two possible configurations:

Pass-through coloring: If you leave these fields blank, the transformer will transfer
the color that is assigned to the primary side (source) to the secondary side
(destination) busbar. For example, if Source 3 feeds the source busbar of a
transformer, and you leave this field blank, then Source 3 will also feed the
destination busbar (and the Source 3 color will be used).

Voltage-level coloring: When you enter top and bottom source numbers, the
transformer colors the one line based on this number. For example, if Source 3
feeds the top of the transformer, but you enter 5 for the bottom source, the
transformer feeds the color from Source 5 to the destination (bottom) busbar.

3. Source and Destination: When you connect to busbars, type the numbers for the
connection source and destination busbars. Valid entries: 1–1000.

4. Label 1 and Label 2: Type the information that you want to appear in the upper left
corner of the genie in the runtime environment.

5. Click OK to save the genie to the page and to return to the graphics builder page.

Configure a Circuit Breaker or Switch

Use this option to configure circuit breakers or switches that you add to a one-line in
the graphics builder.

1. Display the circuit breaker or switch window by pasting the appropriate genie on to
the graphics builder page.

2. Equipment: From the drop-down list, choose the name of the equipment
represented by the genie (this is the equipment name that you entered in the
I/O Device Manager, e.g., CM4Main). To view the equipment that is available for
this page, you must have the project selected in the Citect Explorer.

3. Breaker/Switch Number: Type the number you want to use for this breaker or
switch. Valid entries: 1–1000. This number must be unique within this one-line.

4. Source and Destination: When you connect to busbars, type the numbers for the
connection source and destination busbars. Valid entries: 1–1000.
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5. Label 1 and Label 2: Type the information that you want to appear in the upper left
corner of the genie in the runtime environment.

6. Value Type: From the drop-down list, choose the tag you want to use for this genie.
The related information displays in the lower left corner of the genie in the runtime
environment.

This tag causes real-time data (such as currents) to display on the genie status
page in the runtime environment. If you do not choose a tag here, the status page
will not display the real-time data.

7. Units: From the drop-down list, choose the unit that you would like to display on the
genie in the runtime environment. Units that display here were added in the Profile
Editor.

8. Multiplier: Enter the multiplier that is to be applied to the units chosen in step 7.
9. Click OK to save the genie to the page and to return to the graphics builder page.

NOTE: If you choose to resize a circuit breaker genie after you paste it into a page, you
must keep the relative dimensions (proportions) the same. Otherwise, the racked
in/racked out animation will not display correctly.

Configure an Automatic Transfer Switch (ATS)

Use this option to configure automatic transfer switches (ATS) that you add to a one-
line in the graphics builder.

1. Display the Transfer Switch window by pasting the appropriate genie on to the
graphics builder page.

Transfer Switch Information: Left/Right/Bottom

2. Breaker Number: Type the ID numbers you want to use for the left side and right
side of this ATS. Valid entries: 1–1000. Each number must be unique within this
one-line.

3. Busbar: Type the numbers of the left and right source busbars, and for the
destination (bottom) busbar. Valid entries: 1–1000.

4. Label: For each ATS side, type the information that you want to appear on the
switch in the runtime environment (example: Pri and Emer).

5. Closed Expression: For each side of the switch, type the information that should
display when that side is closed (example: Tag1 <> 1). Do not use "NOT" in the
expression.

Display Information

1. Label 1/Label 2: Type the descriptive information that you want to appear in the
upper left corner of the genie in the runtime environment.

2. Click OK to save the genie to the page and to return to the graphics builder page.

Configure a Busbar

Use this option to configure busbars that you add to a one-line in the graphics builder.
Using this option, you can assign a busbar number to a busbar, and ultimately, to use
busbars to connect genies on a one-line.

Busbar numbers associate devices within drawings, and they help you set up
animation for genies. The busbar entered here is also used for the associated device.

1. Display the busbar window by pasting the busbar genie on to the graphics builder
page.
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2. Busbar Number: type the number you want to use for this busbar. Valid entries: 1–
1000.

3. Line Active: This field is no longer used.
4. Click OK to save the genie to the page and to return to the graphics builder page.

One-Line Colors

In previous versions of the software, line coloring was determined by the line active
state of the busbar. Driven by the busbar color, this state was then fed to all of the
components on that page.

In PowerSCADA Expert 8.1, coloring is based on the source and meter line active
states. Sources dictate the colors for each genie. Meters can only determine if a bus is
active. When the bus is live, the meter then colors based on the source that is
connected to the bus. If there is no source, the default color is used.

NOTE: Depending on how you configure transformers, you can either use this "pass-
through" coloring, or you can use "voltage-level" coloring. See Configure a
Transformer on page 44 for more information.

Assigning Colors

To assign a color to a source, open the Color Configuration tab of the One Line
Configuration Utility (Citect Editor > Tools > One-Line Configuration).

1. Choose the project for which you want to assign colors.
2. Choose the Project Color Palette. Select the project in which the project genies are

defined: usually PLS_Include.

3. For each source or transformer, choose the desired color: click the color cell for that
source/transformer; then choose the color from the dropdown list. You can also
select a color for unknown sources, off, and error. To indicate a flashing color, you
can select two colors.

4. When all colors are assigned, click Save.

Compile the Project
After you install the software and create the project—along with clusters, network
addresses, and servers—perform your first system compile. You will also do this
periodically during system setup.

It is always a good idea to "pack" before you compile. From the Citect Project Editor,
click File > Pack. Then, from the Citect Project Editor, click File > Compile. Correct any
errors and note any warnings.

Review One-Line Page Configurations
Use the Configuration Utility to review genie configurations before you compile a
project. Then you can view errors and warnings, and repair and upgrade genies.

To access this screen, click Tools > One-Line Configuration from the Citect Editor
screen. There are two tabs.

On the Genie Configuration tab, you can:
• view genie types, along with their states (normal, warning, error) and their

properties
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• repair genies that are part of a version 7.30 or later project:
— corrects incorrect breaker, source, meter, transformer, and Sim source numbers
— corrects invalid line active when a connected busbar has a valid line active

• repair and upgrade genies that are part of a project from a version earlier than 7.30
— renumbers ALL breaker, source, meter, and Sim source numbers
— corrects invalid line active when a connected busbar has a valid line active
— reassigns ALL valid busbars

See Review Genie Configurations for information about using this tab.

On the Color Configuration tab, you can assign colors to sources. see One-Line
Colors on page 46 for information about using this tab.

Modify AdvOneLine.csv

After you run the One-Line Configuration Utility, open the project to verify that the
animation is working correctly. If the animation is not correct, repeat the process of
running the utility and verifying out animation until all errors are corrected.

Review Genie Configurations

Use the one-line configuration utility to review genie configurations before you compile
your project.

Errors ( ) and warnings ( ). You must correct errors; otherwise, you may not
be able to compile, and the animation will not work. Although you might not need to
correct warnings, you should review them to ensure that their settings are correct. Note
that, as you hover over an error or warning icon, a tooltip tells you what is wrong with
the genie.

Before you use the compile, do the following:

• If you are upgrading from an earlier version, run Update Pages in the Graphics
Builder.

• Create the pages.

To launch the utility:

1. Make sure you are viewing the system for which you want to view information.
2. From the Citect Editor, click Tools > One-Line Configuration.

A message displays, telling you to that Citect will be hidden.

3. Click OK.

The first time you load the utility, a large system could take a couple of minutes to
load. After that, it should load with a minute.

The utility displays with the following information:

Field Description

Project Default: the project selected in Citect Explorer

Show By:

Type: Information is sorted first by genie type, then by page. This option is useful
when you want to see all genies of a certain type together, regardless of where they
are in the drawing pages.

Page: Information is sorted first by page, then by genie type. This option is useful
when you want to see all genies on a certain page.
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Field Description

Advanced Properties
Check this box to view the basic information plus any additional information relevant
to that genie type.

State Filters:
Check the individual boxes for how you want to view information. For example, you
might only be interested in viewing genies that have error states. This option controls
only the genie information in the right-hand pane.

Genie Types Types are: breakers, busbars, meters, sources, and transformers

Genie Information

Columns of information display:

In the Basic (default) view: themost used information

If you click Advanced Properties, you see the basic information, followed by all of the
information known about the genie(s) you are viewing.

Repair—Upgrade Project

Check this box to cause the repair feature to repair the entire project.

Use this feature only to upgrade projects that are earlier than PowerSCADAExpert
8.1. This option repairs the entire project, renumbering all busbars, breakers, meters,
duplicate Sim sources, and sources. Additionally, busbar line active states are used
to determinemeter and source line active states.

DO NOT perform Repair—Upgrade Project more than once, and do not perform it on
a PowerSCADAExpert 8.1 project.

Repair This feature attempts to repair errors and warnings.

For specific information about each type of genie, click a link below:

Breaker and Switch Information on page 53

Busbar Information on page 52

Meter Information on page 53

Source Information on page 54

Transformer Information on page 55

One-Line Errors and Warnings

Typical one-line errors are:

• CSV formatting errors
• files required by the logic engine are locked or open in another process
• nonexistent tags are specified in CSV conditions
• not running the Computer Setup Wizard for the runtime project

Communication Errors

When communication errors occur, the object that has lost communications gives an
"unknown" status, which is graphically represented in the one-line animation.

Objects in the one-line should be defined to display the communication errors as a
different color. The errors are calculated using the quality of a tag. If a tag or point
becomes invalid, it is assumed that the communication is also off line. When this
occurs, the graphical objects (buses, breaker, and sources) should change to the pre-
set "unknown status" color (the array position 255 in the graphic).
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Error Logging

The most common errors in a CSV file are logged to the Run project in a file named
AdvOneLineStatusLog.txt. The file can contain several messages The table below lists
these errors and their descriptions.

Error Message Description

Main Execution Loop Unexpected Failure
Themain logic loop has thrown an exception that has not been
handled by other error messages.

AdvOneLineDebugBus.Csv is locked
Another process or user has this required CSV file locked.
Ensure that you do not have the file open.

PowerSCADAExpertRunning Project
Path: "PATH"Does not Exist. Please
Shutdown your Project and Try Running your
Computer SetupWizard

The Citect.ini "Run" parameter has an invalid project path that
does not exist. Run the Computer SetupWizard, and this path
should be corrected.

PowerSCADAExpertRunning Project Pth Not
Specified. Please Shutdown your Project and
Try Running your Computer SetupWizard

This problem is almost exclusively caused by not running the
Computer SetupWizard.

PLSCADA is not in runtime
Youmust have your project running before you execute the
AdvOneLine.exe file.

Failed to Establish Connection with CTAPI.
PLSEngine.establishPLSConnection
(FAILED CONNECTION)

This error message indicates the PLS API connection has
unexpectedly been disconnected.

Required CSV file is locked
The CSV file specified (AdvOneLine.csv) is locked by another
process or user. Ensure that you do not have the file open.

Invalid prefix located in
CSVParser.FormatCSVData

The CSV parser has detected an invalid component prefix. This
error message should not occur.

ERROR: Duplicate Component Name
Encountered

Check the CSV file to ensure that you do not have two sources,
meters, or breakers with the same component number.

ERROR: Invalid Node1 Number Encountered
In the Bus1 column, you have a node that is not a number
between 1 and 1000.

ERROR: Invalid Node2 Number Encountered
In the Bus2 column, you have a node that is not a number
between 1 and 1000.

ERROR: Node Not Specified You have a component without a Bus1 and/or Bus2 specified.

ERROR: Invalid Condition String
Encountered (MESSAGE)

You have a syntax error in your condition column. Read the
message. It will give details about the syntax error, the line on
which it occurred, and (if applicable) the character at which it
occurred.

One or more of the tags specified in your CSV
file do not exist in your Runtime SCADA
project

Examine your CSV file. Either add the tags listed above the error
message, or remove the tags from the CSV

By default, only exceptions are logged.

Perform Repairs for One-Lines

Before you begin, back up your project.
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CAUTION
DATA CORRUPTION

Always make a backup copy of your project before you perform a repair.

Failure to follow these instructions can result in data loss and corruption of your
project.

Follow these steps to view the One Line Configuration Utility, and to make repairs to
your projects:

1. Open the utility: From the Citect Project Editor, click Tools > One-Line
Configuration.

The first time you launch this utility, it could take several minutes for it to read all of
the project information.

The utility will read the project's graphics pages to analyse the project. If it appears
that the project is from a version prior to PowerSCADA Expert 8.1, a message
displays, telling you that the project appears to be out of date. The default "Upgrade
Project" is checked in the lower right corner.

2. Click OK.

Genie information for the selected project displays. For descriptions of the fields on
this page, see Review Genie Configurations.

3. Choose the type of repair you want to perform:

Repair option alone (Upgrade Project not checked) attempts to fix errors and
warnings in a project (used for PowerSCADA Expert 8.1).

Repair option with Upgrade Project checked is used to upgrade projects
from previous versions of the product. This option renumbers all genies in the
project. Do not perform this option on a project more than once, and do not perform
it on PowerSCADA Expert 8.1 projects.

NOTE: When two busbars have the same line active, they are assigned the same
busbar number.

The following table describes the repairs made in each option.

Genie Type Repair Repair— Upgrade Project

Breaker Breaker Number ALL Breaker Numbers

Sources
Source Number

Line Active

ALL Source Numbers

Line Active

Meters
Meter Number

Line Active

ALL Meter Numbers

Line Active

Transformers
Sim Source Numbers (top and
bottom)

Sim Source Numbers (top and bottom)

Busbars ----
All valid busbars will be reassigned, including
destination and source busbars for breakers and
transformers

4. Click Repair.

You see a message that describes the degree of repair that is about to take place.

Each message says that graphics pages "will not be modified by the repair
process." This means that the repairs will not be applied to your project graphics
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pages until you press Save.

5. Click Yes to initiate the repair option that you have selected.

A Repair Summary window displays, listing the repairs that have been initiated.

6. To save a .csv copy of this summary, click Export. At the Save As window, type a file
name and choose the location at which you want to save the file.

7. Click OK.

The genie information changes, indicating that the repairs have been made.

8. Click Save.

The Save window appears. This is where the changes are saved to your project.

9. Click Yes to save the changes to the graphics pages of the project.

Or click No to back out of making the changes.

If you click No, click Close, then click No when you are asked whether you want to
save the modified project.

If you click Yes, the changes are saved to the project. For a large project, this might
take several minutes. When the repairs are saved to the project, you see a Save
Summary window, which lists the repairs that were made and saved.

Click Export to save a .csv file of these changes. Click OK to exit the summary
window and return to the One Line Configuration Utility window.

10. It is possible that some errors and warnings will not be repaired, for example,
missing busbar numbers or missing equipment. Click individual errors or warnings
to view them (note that the warning and error icons include a tooltip to tell you what
is wrong). Note the missing information, then go to the graphics builder to make the
necessary changes.

11. Compile the project and then run it.

Automatic Transfer Switch (ATS) Information

ATS Information

The most commonly used information about the ATS genie displays by default.

When the Advanced Properties box is checked, the table expands to include
everything that is known about the selected ATS.

Basic ATS information includes:

Column Description

State Normal ( ), Warnings ( ), or Errors ( ). See the following table for
explanations of errors.

Page
Name of the page on which the genie is found (displays only from the folder
level).

ID
This is the breaker number for the left side, assigned when adding it to a
page of a one-line.

ID2
This is the breaker number for the right side, assigned when adding it to a
page of a one-line.

Source Busbar1 The number of the source busbar for the left side.

Source Busbar2 The number of the source busbar for the right side.

Dest. Busbar The number of the destination busbar.
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ATS Errors

Before you use the drawing, you must correct all errors. Otherwise the project might not
compile; and the animation will not work.

Errors that you might see for ATSs are:

State Solution

Errors ( )

Breaker numbers must be a
number greater than 0 and
unique.

The breaker numbers aremissing, or they are less than or equal to 0. Add or
change the breaker numbers.

Source busbar numbers must be
a number greater than 0.

The source busbar numbers aremissing, or they are less than or equal to 0.
Add or change the source busbar numbers.

Destination busbar number must
be a number greater than 0.

The destination busbar number is missing, or it is less than or equal to 0. Add
or change the destination busbar number.

Source and Destination busbars
must not be equal.

The source and destination busbars have the same number; change one
number.

Either the Source or Destination
Busbar number must exist
(busbar may link to a Busbar,
transformer, meter, source, or
another breaker)

At least one busbar must be linked to this ATS.

Busbar Information

The most commonly used information about the busbar genie displays by default.

When the Advanced Properties box is checked, the table expands to include
everything that is known about the selected busbar(s).

Basic busbar information includes:

Column Description

State Normal ( ), Warnings ( ), or Errors ( ). See the following
table for explanations of errors and warnings.

Page
Name of the page on which the genie is found (displays only from the
folder level).

ID
This is the busbar number, assigned when adding it to a page of a
one-line.

Busbar Errors

Before you use the drawing, you must correct all errors. Otherwise the project might not
compile; and the animation will not work.

Errors that you might see for busbars are:

State Solution

Errors ( )

Busbar number must be a
number greater than 0.

The busbar number is missing, or it is less than or equal to 0. Add or
change the busbar number.
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Breaker and Switch Information

The most commonly used information about the breaker genie displays by default.

When the Advanced Properties box is checked, the table expands to include
everything that is known about the selected breaker(s).

Basic breaker information includes:

Column Description

State Normal ( ), Warnings ( ), or Errors ( ). See the following table for
explanations of errors.

Page
Name of the page on which the genie is found (displays only from the folder
level).

ID This is the breaker number, assigned when adding it to a page of a one-line.

Equipment
The equipment name entered when adding the genie via the ProfileWizard or
Automation Interface.

Source Busbar The number of the source busbar.

Dest. Busbar The number of the destination busbar.

Breaker and Switch Errors

Before you use the drawing, you must correct all errors. Otherwise the project might not
compile; and the animation will not work.

Errors that you might see for breakers are:

State Solution

Errors ( )

Breaker number must be a
number greater than 0 and
unique.

The breaker number is missing, or it is less than or equal to 0. Add or change
the breaker number.

Source busbar number must be a
number greater than 0.

The source busbar number is missing, or it is less than or equal to 0. Add or
change the source busbar number.

Destination busbar number must
be a number greater than 0.

The destination busbar number is missing, or it is less than or equal to 0. Add
or change the destination busbar number.

Source and Destination busbars
must not be equal.

The source and destination busbars have the same number; change one
number.

Equipment must be present.
There is no equipment attached to the breaker. Add the appropriate
equipment.

Either the Source or Destination
Busbar number must exist
(busbar may link to a Busbar,
transformer, meter, source, or
another breaker)

At least one busbar must be linked to this breaker.

Meter Information

The most commonly used information about the meter genie displays by default.

When the Advanced Properties box is checked, the table expands to include
everything that is known about the selected breaker(s).

53 © 1990–2016 Schneider Electric All Rights Reserved

7EN02-0382-00 Create the Operator HMI
03/2016



Basic meter information includes:

Column Description

State Normal ( ), Warnings ( ), or Errors ( ). See the following table for
explanations of errors and warnings.

Page
Name of the page on which the genie is found (displays only from the folder
level).

ID This is themeter number, assigned when adding it to a page of a one-line.

Equipment
The equipment name entered when adding the genie via the I/O Device
Manager.

Source Busbar The number of the incoming busbar.

Line Active
The Cicode expression (such as MyTag1 >0) that determines when the
meter detects power on the busbar.

Meter Errors and Warnings

Before you use the drawing, you must correct all errors. Otherwise the project might not
compile; and the animation will not work.

Warnings indicate settings that might be incorrect. Verify that the settings indicated by
the warnings are what you want.

Errors and warnings that you might see for meters are:

State Solution

Errors ( )

Meter number must be a number
greater than 0 and unique.

Themeter number is missing, or it is less than or equal to 0. Add or change
themeter number.

Busbar number must be a
number greater than 0.

The busbar number is missing, or it is less than or equal to 0. Add or change
the busbar number.

Equipment must be present.
There is no equipment attached to themeter. Add the appropriate
equipment.

Busbar number must exist
(busbar may link to a Busbar,
transformer, meter, source, or
breaker)

At least one busbar must be linked to this meter.

Warnings ( )

Line Active should be present. Line Active should be entered to determine when themeter detects power.

Busbars across all meters should
be unique.

Verify that all busbars connected to this meter have the correct, unique,
numbers.

Source Information

The most commonly used information about the source genie displays by default.

When the Advanced Properties box is checked, the table expands to include
everything that is known about the selected source(s).

Basic source information includes:
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Column Description

State
Normal ( ), Warnings ( ), or Errors ( ). See the

following table for explanations of errors and warnings.

Page
Name of the page on which the genie is found (displays
only from the folder level).

ID
This is themeter number, assigned when adding it to a
page of a one-line.

Busbar
The number of the source that powers the connected
busbar.

Line Active
The Cicode expression (such as MyTag1 >0) that
determines when the source detects power on the busbar.

Source Errors and Warnings

Before you use the drawing, you must correct all errors. Otherwise the project might not
compile; and the animation will not work.

Warnings indicate settings that might be incorrect. Verify that the settings indicated by
the warnings are what you want.

Errors and warnings that you might see for sources are:

State Solution

Errors ( )

Source number must be a
number greater than 0
and unique.

The source number is missing, or it is less than or equal to
0. Add or change the source number.

Busbar number must be a
number greater than 0
and unique across
sources.

The busbar number is missing, or it is less than or equal to
0. Add or change the busbar number.

Busbar number must
exist (busbar may link to
a Busbar, transformer, or
breaker)

At least one busbar must be linked to this source.

Warnings ( )

Line Active should be
present.

Line Active should be entered so the source can detect
power on the busbar.

Transformer Information

The most commonly used information about the transformer genie displays by default.

When the Advanced Properties box is checked, the table expands to include
everything that is known about the selected transformer(s).

Basic transformer information includes:
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Column Description

State
Normal ( ), Warnings ( ), or Errors ( ). See the following table for

explanations of errors.

Page
Name of the page on which the genie is found (displays only from the folder
level).

ID This is the breaker number, assigned when adding it to a page of a one-line.

Source Busbar The number of the source busbar.

Dest. Busbar The number of the destination busbar.

Sim. Source This is the top source number used when adding the transformer.

Sim. Source 2 This is the bottom source number used when adding the transformer.

Transformer Errors

Before you use the drawing, you must correct all errors. Otherwise the project might not
compile; and the animation will not work.

Errors that you might see for transformers are:

State Solution

Errors ( )

Source busbar number must be a
number greater than 0.

The source busbar number is missing, or it is less than or equal to 0. Add or
change the source busbar number.

Destination busbar number must
be a number greater than 0.

The destination busbar number is missing, or it is less than or equal to 0. Add
or change the source busbar number.

Source and Destination busbars
must not be equal.

The source and destination busbars have the same number; change one
number.

Either the Source or Destination
Busbar number must exist
(busbar may link to a Busbar,
transformer, meter, source, or
another breaker)

At least one busbar must be linked to this transformer.

If a top or bottom source is
identified, it must be greater than
0.

The number for the top or bottom source for this transformer must be greater
than zero (for voltage-level transformers) or must be left blank (for pass-
through transformers).

Add Users
This section discusses how to set up user IDs and passwords for the project. For safety
reasons, only advanced users should be given access to such features as controls and
resets. User access rights (privileges) are defined in System > Roles form, in the Citect
Project Editor.

NOTE: The Default_Starter project includes a default user, with ID/password the
same: aol/aol.

You can use single sign on (SSO) to associate passwords for different products (such
as Citect with PowerSCADA Expert and Advanced Reporting Module). SSO allows the
Citect user, when logged in to runtime, to access external applications, such as
dashboards. For information on setting up SSO, see Security: Single Sign On in:

Configure Single Sign-On (SSO) on page 83
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Default User Access Settings (Privileges)
The following table describes the access rights. These privileges are included in
PLSSecurity.ci file (in the PLS_Include project). Any changes made to this file will be
overwritten when PLS_Include is updated (every new release). Document every
change you make, so that you can update PLSSecurity.ci when PLS_Include is
upgraded.

Access Right Roles / Global Privileges

Description Access Level Label

Acce
ss
Level
Value

Operato
r1

Operato
r2

Engine
er

Administra
tor

Kern
el

2 4 6 7 8

Circuit breaker,
switch control

PL_Sec_CBControl 1 X X X X

IED configuration PL_Sec_IEDConfig 2 X X X

Circuit breaker
tagging

PL_Sec_Tagging 3 X X X

Alarms
acknowledgment

PL_Sec_AlmAck 4 X X X X X

Alarm deletion PL_Sec_AlmDelete 5 X X X

Alarm configuration PL_Sec_AlmConfig 6 X X X

Add/remove log-in
users

PL_Sec_UserConfig 7 X X

Reset alarms in
device

PL_Sec_AlmReset 8 X X

Shutdown runtime PL_Sec_Shutdown 9 X X X

View waveforms
PL_Sec_
ViewWaveform

10 X X X X X

NOTE: Privileges 1, 3, and 5 are currently unused. You can use them as you wish.

A method of limiting access to the design time/configuration environment is to remove
the user rights to certain PowerSCADA Expert files. From the server, use Windows
security to remove user accounts from individual features. For example, access to the
following .exe files should be restricted to users who have design time/configuration
privileges.

• CtDraw32.exe - Graphics builder
• CtEdit32.exe - Project Editor
• CtExplor.exe - Project Explorer
• ProfileWizard.exe - I/O Device Manager
• ColorSwap.exe - Color Swap Tool
• ProfileEditor.exe - Profile Editor

All of these files need to have the same level of security, as they are interrelated.

Additionally, to prevent users from accessing and changing the code responsible for
enforcing user security in the runtime environment, you need to lock down the user
rights for the Cicode files (.ci extension) in the PLS_Includes project.

NOTE: Another way to lock users out from changing an existing project is to implement
read-only projects.
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Add and Modify User Accounts
You must add at least one user to any project before you can run and view it. Each
user must have a role and a user account.

We recommend that you use Windows Authentication when you create user accounts.

Terms you need to understand are:

• privilege: the level of access that is applied to a system element; a user account
has individual privileges, which the user can then control

• role: contains a defined set of privileges, that are assigned to users

The Users screen controls all of the user access levels for each project. To assign user
access, follow these steps:

1. From the PowerSCADA Expert Explorer, choose the project for which you want to
assign user access.

2. From the Project Editor, click System > Roles.

3. For the first user, assign a user role, Windows group name (optional), and global
privileges. If you need additional information, click Help from that screen. For global
privileges, see the table in Default User Access Settings (Privileges) on page 57 for
the level of each type of access right.

4. After you add the first role, click Add.

5. From the Project Editor, click System > Users.

6. Assign a user account. If you need additional information, click Help from that
screen.

7. After you add the first user, click Add.

8. To add additional users, do the following: with a user displayed, click Add (which
creates a copy of the user); type the new user information in place of the old
information; then click Replace to overwrite the information.

Note that the record count increases by one with each addition. To view the users
one at a time, scroll through the list.

Use Windows Integrated Users

Instead of using the above method to define users in the project, you can incorporate
PowerSCADA Expert users and security options with the standard Windows security
system. Using the integrated Windows security feature, the Windows user can log on to
PowerSCADA Expert runtime with runtime privileges and areas configured within the
project. For a Windows user to be able to log on to runtime, it must be linked to a
PowerSCADA Expert "role," which is defined in the project with associated privileges.

To link a Windows user to a PowerSCADA Expert role, add the "role" that specifies the
Windows security group of which the Windows user is a member.

The pre-existing AutoLogin capability is extended to include the client, when the user
is a Windows user, having an associated PowerSCADA Expert role. In order to invoke
this functionality for a Windows user, you need to set the [Client]AutoLoginMode
parameter in the Citect.ini file.

Instead of using auto-login when the system starts up, users can also log in to
PowerSCADA Expert using any Windows user credential that is a member of the linked
group.

When the name of a PowerSCADA Expert user also has the same name as a Windows
user, the PowerSCADA Expert user takes priority at runtime. However, if a valid
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PowerSCADA Expert user login does not succeed for some reason, the Windows user
credentials will not be checked and an alert will be generated to advise that the login
was not effective.

For more information, see Using PowerSCADA Expert with Windows
Security in the citectSCADA.chm help file (Program Files> Schneider Electric >
PowerSCADA Expert > v8.1 > bin).

Integrate with the Schneider Electric Security Access Module

If the Schneider Electric Security Access Module (SAM) is a part of the customer's
solution, any domain/users created in the SAM can be used in PowerSCADA Expert in
the same manner as described above in Use Windows Integrated Users. To do this,
add a role to the PowerSCADA Expert project,and use the name of the SAM security
group in the role's "Windows Group" field.
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Compile the Project
After you install the software and create the project—along with clusters, network
addresses, and servers—perform your first system compile. You will also do this
periodically during system setup.

It is always a good idea to "pack" before you compile. From the Citect Project Editor,
click File > Pack. Then, from the Citect Project Editor, click File > Compile. Correct any
errors and note any warnings.
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Create Project Menus
Content in the graphics pages is controlled in the pagemenu.dbf file. Use
pagemenu.dbf to create the tabs and sub-tabs that will display on each graphics page.
An example of a pagemenu.dbf file, for the PLS_Example project, is located in:

C:\ProgramData\Schneider Electric\PowerSCADA Expert\v8.1\User\PLS_Example.

The pagemenu.dbf file for your project is in the same User directory, in the folder that
matches your project name.

For instructions on adding a new graphics page, see:

Create a One-Line Graphics Page on page 41

For instructions on editing the pagemenu.dbf file, see:

Add Pages to Project Menu Configuration on page 61

To create new genies for a project, see:

Enter Genie Properties on page 43

Add Pages to Project Menu Configuration
The Menu Configuration form (System > Menu Configuration in Project Editor) edits
Pagemenu.dbf in your project. This controls the runtime environment screen
appearance: tabs and menus on the screen. By the entries you add there, you can also
specify actions to be taken when an option is selected.

Because it takes much effort to create the items that display on a graphics page, you
can use the menu settings from the PLS_Example project as a template for your new
project template. From it, you can copy and paste settings into an individual project’s
menu configuration file.

The following illustrates a blank Menu Configuration file (see the table below for
descriptions of the numbered fields):
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Menu Item Description

1: Order
The relative position within the final graphics page. If you leave this field blank, the
default value 0 is used. (64 characters maximum)

2: Levels 1 through 4
These items establish themenu levels that will display. For example, youmight use
"Single Lines" for level 1, followed by the substation for level 2, and the graphic name for
level 3. (Each line: 256 characters maximum)

3: Menu Command

The Cicode expression that you want to execute. Typically, you will use the "page
display" command followed by the actual page you want to see. For example:

PLSPageDisplay("CB_IEC_1")

which displays the page CB_IEC_1.

4: Symbol

Displays a defined image along with the description for that level.

Images must already be defined in the project/include project. They are specified in the
format <library name>,<symbol name>. For example, in PLS_Example, the symbol used
for the level 2 of Single Lines is Substation3, entered as PLS_Icons.Substation3.

Different menu levels are designed to be used with different symbol sizes for optimal
display. For Level 1 items (tab), the recommended symbol size is 16 x 16 pixels. For
Level 2 items, (buttons), the recommended symbol size is 32 x 32 pixels. Symbols are
not displayed for menu items of Level 3 or beyond.

5: Comment You can use up to 128 characters to add a comment (will not display on screen).

To copy information from the PLS_Example project, do the following:

1. Open the PLS_Example project. Then, from the Citect Project Editor, click System >
Menu Configuration.

The Menu Configuration for PLS_Example displays.

2. From Citect Explorer, change the project to your new project.

3. In the Citect Project Editor, click Menu Configuration.

Now both Menu Configuration windows display.

4. To copy the entire record, you can use the Copy Record and Paste Record menu
command. From the desired record in the PLS_Example project window, select the
menu command Edit > Copy Record. Then go to the desired record in your project
window, and select menu command Edit > Paste Record. Do further editing as
required. Alternatively, you can selectively copy information from the source record
to your project, line by line.

5. To save the menu configuration record in your project, choose either the "Replace"
or "Add" button. Save your changes in .dbf format.

6. From the Citect Project Editor, pack the project (File < Pack). Compile the project;
then run it again.

The Graphics page in the runtime environment of your project will now display
according to the settings you have made.

Add One-Line Pages
As indicated in the table above, you can easily add menu items for your one-line
diagram pages by providing Level 1 - Level 4 menu item names and then using the
PLSPageDisplay function in the Menu Command field to display your one-line pages
by name. Do this for each one-line page you wish to add to your project navigation.

Follow these steps for each alarm page you want:

1. From Citect Project Editor, click System > Menu Configuration.
2. In the Menu Command line, add the Cicode method that will open the page:

PLSPageDisplay("SLD_33_KV_IEC")
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3. In the Symbol line, type the appropriate symbol/size information. See the table
aboveAdd Pages to Project Menu Configuration on page 61for information on this
field.

Add Alarm Pages
Use this procedure to create separate alarm pages for each alarm type in the project.
Follow these steps for each alarm page you want:

1. From Citect Project Editor, click System > Menu Configuration.
2. In the Menu Command line, add the Cicode method that will open the page:

PLSDspShowAlarm(INT nType)

where nType = the type of alarm (e.g., 1=unacknowledged, 3=disabled)

Example (for disabled alarms):

PLSDspShowAlarm(3)

For information about alarm types, see AlarmDsp in the Cicode Programming
Reference help file.

The PLS_Example project also has many good examples for how to add each alarm
page to your project. In PLS_Example, click System > Menu Configuration from the
Citect Project Editor. You will see all active alarms in a page named "Alarm Log" with
AlarmType=0.

Add the Tag Viewer Page Menu Item
The tag viewer is a feature that displays in the graphics page during runtime . Use the
tag viewer to view details about equipment and real-time tag data values. This screen
provides the status of project tags.

To add the tag viewer to a project graphics page, follow these steps:

1. From the Citect Project Editor, click System > Menu Configuration.
2. In the Menu Command line, add the Cicode method that will open the page:

PLSPageDisplay("PLSTagView")

When viewing the tag viewer in runtime, as long as the screen resolution is one that
Citect supports, the view will be correct.

For information about viewing tags, see Use the Tag Viewer on page 107.

Add the Advanced Reports Root Page Menu Item
1. From the Citect Project Editor, click System > Menu Configuration.
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2. Enter the call to the ShowWebReportDsp function (found in the PLS_Applications.ci
file), with 0 entered for the ReportID and the page title.

3. If you have multiple reports configured, and want to display a different report for
different devices, repeat this procedure for each button, with the correct ReportID.

4. Save, compile, and run the project to test the functionality.

NOTE: Carefully consider how and where you display the web report root.
PowerSCADA Expert has native reports, and the customer should see as consistent
interface an as possible. When you modify the menu, you can better maintain the
experience of a single HMI if you remove certain native links (in the PLS_Example
project) and if you are selective about where the root is displayed.

About the PLS_ShowWebReportDsp Cicode: In this step, you call the PLS_
ShowWebReportDsp function from a menu configuration. This function is part of the
Cicode in the PLS_Applications.ci file, which is packaged with this document. The
code is shown below for reference.

FUNCTION PLS_ShowWebReportDsp(INT iReportID, STRING sTitle = "")

IF ("" = sTitle) THEN sTitle = "Reporting"; END

STRING sUrl = _PLS_Apps_BuildWebReporterUrl(iReportID);

IF ("" <> sUrl ) THEN

PLS_WebDsp(sUrl, sTitle, "PLS_ShowWebReportDsp",

IntToStr(iReportID) + ",^"" + sTitle + "^"");

END

END

Important things to note about this code:
• iReportID is the unique identification number of the desired report, determined in

the step below.
• sTitle is the title of the page.
• The function builds a URL based on the provided Host in the Citect.ini.
• It will also dynamically create the object with PLS_WebDsp so there is no need for

an AN object name reference.

NOTE: After you are on the Web Reporter page, you stay logged in until you close the
browser or refresh the page.
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Add Specific Advanced Reports Page Menu Items
Use this procedure to add menu items that navigate directly to a saved Advanced
Report, such as a report for energy analysis over the last two months.

NOTE: After you are on the Web Reporter page, you stay logged in until you close the
browser or refresh the page.

1. From the Citect Project Editor, click System > Menu Configuration.

NOTE: You will later determine the ReportID that you enter below in this section:
Determine the Advanced Reports Report ID to Use In PowerSCADA on page 82. You
can repeat this procedure to add menu items for each of the saved reports that you
want to display from the PowerSCADA Expert navigation menus.

2. Enter the call to the ShowWebReportDsp function (found in the PLS_Applications.ci
file), with 0 entered for the ReportID and the page title.

3. If you have multiple reports configured, and want to display a different report for
different devices, repeat this procedure for each button, with the correct ReportID.

4. Save, compile, and run the project to test the functionality.

NOTE: Carefully consider how and where you display the web report root.
PowerSCADA Expert has native reports, and the customer should see as consistent
interface an as possible. When you modify the menu, you can better maintain the
experience of a single HMI if you remove certain native links (in the PLS_Example
project) and if you are selective about where the root is displayed.

Add the Dashboards Page Menu Item
Add a Menu Item to Launch a Dashboards Slideshow

1. In the Citect Project Editor, click System > Menu Configuration. Enter the call to the
PLS_ShowDashboardDsp function (found in the PLS_Applications.ci file), with the
slideshow (if desired), and the page title.

The following image illustrates the settings for "with optional slideshow GUID,"
which loads a specific dashboard

NOTE: You will determine the slideshow GUID later when you set up the Advanced
Reporting and Dashboards server. See Determine the Dashboards Slideshow ID to
Use In PSE on page 81
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2. If you create multiple slideshows and you want to display a different dashboard for
each slideshow, repeat these steps for each button, using the correct slideshow
name.

3. Save and compile. Then run the project to test functionality.

About the PLS_ShowDashboardDsp Cicode: In this step, you call the PLS_
ShowDashboardDsp function from a menu configuration. The code is:

FUNCTION PLS_ShowDashboardDsp(STRING sSlideShow = "", STRING sTitle
= "")

IF ("" = sTitle) THEN

IF ("" = sSlideShow) THEN

sTitle = "Dashboards";

ELSE

sTitle = "Dashboards - " + sSlideShow;

END

END

STRING sUrl = _PLS_Apps_BuildDashboardUrl(sSlideShow);

IF (sURL <> "") THEN

PLS_WebDsp(sUrl, sTitle, "PLS_ShowDashboardDsp",

"^"" + sTitle + "^"");

END

END

Important things to note about this code:

• sSlideShow is an optional parameter to call a predefined dashboard slideshow.
• sTitle is the title of the page.
• The function builds a URL based on the provided host in the Citect.ini.
• It will also dynamically create the object with PLS_WebDsp so there is no need for

an AN object name reference.

Add a Page Menu Item to Launch a WebDiagram
The following procedure describes how to access a WebDiagram by invoking cicode
from your project menu, however later procedures here describe how to alternatively
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add a WebDiagram view in your genie equipment popup. SeeAdd Web Diagrams to
Equipment Popups on page 94 for more information.

To add a new page to the project which will display a given WebDiagram, create a new
menu configuration item which calls the PLS_WebReachDsp cicode explained below.
In the Citect Project Editor, click System > Menu Configuration. Enter the call to the
PLS_WebReachDsp function (found in the PLS_Applications.ci file), with the
slideshow (if desired), and the page title.

About the WebReachDsp Cicode

In the following step, you will call the WebReachDsp function from a button. This
function is part of the Cicode in the PLS_Include.ci file, which is packaged with this
document. The code is shown here for reference:

FUNCTION PLS_WebReachDsp(STRING sDeviceName, STRING sTitle = "")

STRING sPage = PLS_GetWebReachURL(sDeviceName);

IF ("" = sPage) THEN RETURN; END

IF ("" = sTitle) THEN sTitle = sDeviceName; END

PLS_WebDsp(sPage, sTitle);

END

There are some important things to note about this code:

• sDeviceName is the name of the device, determined in the step above.
• sTitle is the title of the page

If the diagram does not display, try the following troubleshooting steps:

• Enter the URL of the diagram directly into a browser window; verify that it launches

The URL is: http://[servername]/ION/default.aspx?dgm=OPEN_TEMPLATE_
DIAGRAM&node=[device name]

If this does not work, verify that the WebReachServer is correct in your citect.ini, and
the diagram appears correctly in WebReach.

• The steps above should resolve most issues. One last option is to test by putting the
web browser in a window on the calling page.
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Compile the Project
After you install the software and create the project—along with clusters, network
addresses, and servers—perform your first system compile. You will also do this
periodically during system setup.

It is always a good idea to "pack" before you compile. From the Citect Project Editor,
click File > Pack. Then, from the Citect Project Editor, click File > Compile. Correct any
errors and note any warnings.
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Configure the One-Line Engine and the Citect Data Platform
Settings

Use this section to set up advanced one-lines and to configure the credentials and
redundancy settings for the one-line engine and Schneider Electric CoreServiceHost
service.

Access the Application Configuration Utility via the desktop link or the Start menu:
Start > All Programs > Schneider Electric > PowerSCADA Expert 8.1 > Config Tools >
Application Config Utility.

Click the links below to configure one-line settings and set up the Citect data platform:

One-Line Engine

Citect Data Platform

One-Line Engine
There are three tabs in the One-Line Engine module. On all three tabs, two buttons at
the bottom allow you to:

Restart AOL: Click to manually restart the Advanced One Line engine.

Save: Click to save the settings you have entered.

NOTE: When running the Citect project as a Windows service, Advancedoneline.exe
must run on session 0. To achieve this, execute your advanced online startup code
from an IOServer rather than from a client.

The three tabs are:

• Citect User: After you add a user to your Citect project, use this tab to test whether
the user ID can be used by the One Line engine to connect with runtime. Type the
Citect user ID and password, and click Test Credentials. The test will attempt to log
in with this user information. A message displays, telling you whether the user
information passed. If it does not pass, you see a message telling you that the
connection failed because the user name/password are incorrect or
PowerSCADA Expert is not running. Make sure that PowerSCADA Expert is
running and that the user name/password have been set up in Citect, then try
again.

• Redundancy:
— Primary Server IP: used in redundant configurations to specify the IP address of

the primary IOServer. Click Clear to clear the current address, then type the
correct address for the primary server.

— Standby Server IP: used in redundant configurations to specify the IP address of
the standby IO Server. Click Clear to clear the current address, then type the
correct address for the secondary server.

Citect Data Platform
This section relates to how the core service host connects to Citect.

Use this page to link a Citect user name and password to be used when the Schneider
Electric CoreServiceHost services connect with Citect runtime. Before you begin:

• Add the username/password to the Citect project.

• Have Citect running in runtime mode.

Then follow these steps:
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1. Citect I/O Server Address: Choose the server address for the project that is
running. (May be left blank if you use a local connection and you are running
PowerSCADA Expert as a service.)

2. Citect User Name: Type the user name of a user configured in the project.
3. Citect Password:Type the password for the Citect project user entered above.
4. Test Credentials: Click to verify these credentials. If you see an error, verify the

name and password, and that Citect runtime is running, and try again.

When your Citect project is running and the credentials are valid, you see
Connection Successful. The user name and password can be used to connect to
Citect.

Citect Licensing Details: This is a read-only field that displays the license key
currently in use on the Citect server machine.
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Compile the Project and Launch the Runtime HMI
After you install the software and create the project (along with clusters, network
addresses, and servers, perform your first system compile. You will also do this
periodically during system setup.

It is always a good idea to "pack" before you compile. From the Citect Project Editor,
click File > Pack. Then, from the Citect Project Editor, click File > Compile. Correct any
errors and note any warnings.

Run the Computer SetupWizard

1. From the Citect Project Editor, click Tools > Computer Setup Wizard.
2. Choose Custom Setup. and Multi-process mode.

3. Check the "Networked" box, instead of Standalone.

4. Enter a "Server Password," though you do not need to remember this password.

5. Choose "Kernel on Menu,: which will help with future troubleshooting.

Launch the Runtime HMI

To launch the runtime environment, do one of the following:

• Click Start < Programs > Schneider Electric > PowerSCADA Expert 8.1 >
PowerSCADA Expert Runtime.

• From any of the Citect windows, click File > Run.

If you are running SCADA as a Service, navigate to the PowerSCADA Expert bin
directory and launch the Service Display client shortcut.
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Verify That I/O Devices are Communicating
After the system is configured and communicating in runtime mode, you need to verify
that all devices are communicating correctly. All devices that are not communicating
should trigger "Communication Failure" alarms, which can be seen in the active alarm
log screen. For instructions on adding this screen to the project, see Add Alarm Pages
on page 63Add Alarm Pages on page 63On the Menu Configuration page, use
PLSDspShowAlarm(0) as the menu item Menu Command.

Use one of the following methods to test communication.

View the graphics pages.

1. Create a graphics page containing an appropriate genie selected from the pls_
meter library, found in the pls_include project.

2. Assign the selected genie to the specific device needed to verify communications.

3. Save the page and compile the project.

4. In runtime mode, double-click the genie to open the genie pop-up. Verify that the
updated readings displayed by the genie match the actual values on the meter
itself. If the readings match, you have verified the device is communicating.

The following illustration shows a genie and its related genie pop-up.

Use the Tag Viewer to learn the status of all project tags.

During runtime, open one of the pages that displays real time tag values. The example
below is PLSTagView. Compare the values displayed on the TagViewer page to actual
values displayed on the meter itself. If the compared values match then you have
verified communications with that device.
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See also:

Add the Tag Viewer Page Menu Item on page 63 and

Use the Tag Viewer on page 107

Use the One-Line Configuration Utility to verify that devices are connected and
animations are working.

The electrical system must be in a non-critical state so that the breakers being used will
not cause any adverse effects (such as putting a person’s safety at risk or affecting a
process). Breaker genies should be able to remotely operate the breaker.

DANGER
HAZARD OF ELECTRIC SHOCK, EXPLOSION, OR ARC FLASH

• Do not rely solely on the display of the genie on the one-line.
• Use this procedure only during development, and not on a live deployed sys-

tem.
• Before energizing or de-energizing any equipment from this software, verify that

all personnel are at a safe distance from all energized equipment.
• Before testing, verify that the proper lock out/tag out procedure is followed, to

ensure that the equipment is in an electrically safe condition.
• Ensure that all safety regulations and procedures have been followed before

you work on the equipment.

Failure to follow these instructions will result in death or serious injury.

In the Graphics Builder, create a one-line diagram with breaker genies that use the
breakers you want to verify. Use the proper logic and passwords to configure the one-
line on the diagram. After the diagram is successfully created, open the graphic page
in runtime mode.

The breaker genie status indicator should mirror the current breaker state. Also, the
busbar color should accurately reflect the electrical state of the conductors connected
to the breaker.
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The following illustrates the appearance of the one-line drawing with breakers first
open and then closed. Note the color change, from black to green (energized), and the
position and current changes on the breakers.

See also:

Review One-Line Page Configurations on page 46

Communications Losses

When you bring your system on line, if you find that PowerSCADA Expert has lost
communications with a device, check the following:

• Verify that the physical connection is correct and secure.
• Verify the IP address.
• Verify the Modbus address.
• Check the statusRegister, statusRegistersCount, and statusRegisterType (see for

details)
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Create and Save Real-Time Data Views in LiveView
Create and view LiveView templates and views for real-time data tables. Some basic
predefined templates are included with the software; you can create new templates or
make copies of the predefined templates and edit the copies.

Before you view LiveView templates and views, you must set up data acquisition
parameters. To do this, use the Application Configuration Utility. See Citect Data
Platform on page 69 for instructions.

NOTES:
• If you find that a predefined table does not include enough cells for the data you

want to display, use the duplicate feature to make a copy of the predefined table.
Then add the needed cells to the duplicate.

• If you install Matrikon Explorer on the same computer as PowerSCADA Expert 8.1,
the LiveView and reporting features will not launch. To prevent this, install Matrikon
before you install PowerSCADA Expert 8.1. If you install Matrikon after you install
PowerSCADA Expert 8.1, you need fix the issue in this way: Go to IIS > ISAPI
Filters, and then reset the dll that is already selected (click browse and re-select
v4.0.30319 aspnet_filter.dll). Click OK.).

You can only view data in these templates if your system is online and you are
connected to devices that provide data.

To set up LiveView real-time data tables in the operator HMI use the following
procedure:

1. Open the LiveView Viewer in your internet browser:
http://localhost/LiveViewViewer

2. Create a custom template (see Create a Template below) or choose an existing
template.

3. Select devices from which to show real-time data

4. Save the view, providing a name.

Keep track of the names of your saved views in order to later use these names in
creating menu items for displaying these views in the operator HMI.

Create a Template
To begin creating LiveView templates, click Start > Programs > Schneider Electric >
PowerSCADA Expert 8.1 > Config Tools > Table Editor. The LiveView Template Editor
screen displays.

1. Open LiveView Setup, then click New.

An empty template displays with a "New Template" name.

2. Overwrite the template name with a name of your choice, up to 100 characters
(limited to A–Z, a–z, 0–9, spaces, underscores, hyphens, and parentheses).

3. To continue setting up the template, click one of the links below.

Template Name: default: New Template (or, if an earlier New Template exists,
appended with a 1)

Single Device/Multiple Devices. The default is single device. If you want a
multiple device table, click Multiple Devices.

NOTE: Table grid lines do not display in the LiveView Viewer, but they do display in
LiveView Setup.
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Formulas
Follow these instructions to add the formulas needed to include data in a Live View
template. You can add formulas to:

• add, subtract, multiply, or divide the contents of two individual cells
• add, multiply, or average the contents of a range of cells

To use this feature, click the Formulas subtab in LiveView Template Editor. Then
choose one of the following fields:

• Cell: Use this field to enable a formula for two individual cells. Then enter:
Cell 1 Address: Type the cell address. The cell address displays in this field.
Operator: Choose the operator you want to use: +, –, *, or /.
Cell 2 Address: Type the cell address. The cell address displays in this field.

• Cell Range: Use this field to enable a formula for a range of cells. Then enter:
Operation: Choose average, product, or sum.
Cell Range: Type the cell range (format C4:C20), or select the range of cells to
include in the formula. The cell range displays in this field.

• Insert Location: Type the cell number.
• Insert: Click this button to build the formula you have specified, and to add it to the

cell you added to Insert Location.

Repeat the above procedure for the rest of the formulas you want to use for this Live
View template.

NOTES:
• You must "Protect Current Sheet" in order for formulas to be maintained and visible

in the LiveView Template Editor.
• If you want to use conditional formulas ("IF" formulas), you must first create them in

Excel. To do this, you must access the template you want on the server (Program
Files > Schneider Electric > Applications > LiveView > TemplateEditor >Templates
Temp). Open the template in Excel and add the conditional formula(s) that you
want. After you save the changes, the formula(s) will function correctly in Live View.
You must copy the IF statement into every cell of the column that displays the result
of the IF statement.

• In multiple device tables that rely on formulas to display information for each
device, the results column will display zeroes when that row has no device in it. To
avoid this, use a formula that will display no result if there is no device in that row. In
the following example, when no device is in cell A2, no results will display (no
zeroes) in cell E2.

Placeholders
Placeholders provide the data (device names and tag names) to a LiveView template.
The placeholders are the identifiers that are added when setting up the template, but
are replaced with the name of the selected device or the tag value when the template
is viewed.
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To use this feature, click the Placeholder subtab in LiveView Template Editor.Then
enter the appropriate information in the following fields.

1. To begin, place the cursor in a cell. Note that the Insert Location displays the cell
number for the placeholder you are setting.

2. TAG Value/Device Name:

From the drop-down field in the top left corner of the page, choose either Tag Value
or Device Name.

Tag Value: Select the tag group, such as Alarm, Current, Energy. Beneath the tag
group, select the specific tag you want. The list is filtered to include only the most
common tags that belong to the group you selected. To view all of the tags
available in this tag group, check Show Advanced.

Device Name:The list of devices is filtered to include only devices for which this
template's data is available. To display the device name in this cell of the template,
select Device Name. You will choose the actual device during runtime.

3. Insert Location: This offers a second way of inserting the placeholder location.
After choosing the device or tag, type the cell number for the placeholder cell.

4. Insert: Click to add the selected placeholder to the specified cell.

Continue adding placeholders as needed.

Thresholds
Use this feature to display tag readings that fall outside of the normal range. You can
apply it to an individual cell or a range of cells. You determine the tag or tags for which
you want to display out-of-normal (threshold) readings. When the value of the tag in a
cell (or any tag in a cell range) is below the minimum or above the maximum that you
set, the tag value displays in the threshold cell.

You can set both minimum and maximum values for a cell or cell range. Use different
colors to indicate the high and low readings.

To use this feature, click the Threshold subtab in LiveView Setup. To add a threshold:

1. Cell: For a single cell: Select the cell for which you want the font color to change.
The font color will change when the value for the tag in that cell goes above the
specified Max Value (or below the Min Value) for the threshold.

or

Cell Range: For a range of cells, either select the range, or type the range in the
format C4:C20.

NOTE: When setting up a multiple-device table, you should use a cell range to
ensure that threshold font colors display for each device in the table.

2. Min Value: Type the low value for the "normal" range. If the tag value drops below
this value, the cell font color will change as specified in step 3.

3. BelowMin Threshold Color: Open the color palette and select the font color that
you want to indicate the "low" status.

4. Max Value: Type the high value for the "normal" range. If the tag value goes above
this value, the cell font color will change as specified in step 5.

5. Above Max Threshold Color: Open the color palette and select the font color that
you want to indicate the "high" status.

6. Insert Location: Choose an empty cell, one that is not part of the table. This cell will
be the location for the threshold definition that you are creating.
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The default cell for the threshold definition is the next available cell in the template.
For example, if the tag in cell B7 has an unused cell to the right of it (C7), the
threshold definition defaults to C7. Then, when the value in B7 exceeds the
threshold defined in C7, the value in B7 displays in the font color you specified. To
override the default cell location, change it in the Insert Location field.

7. Insert: Click here to create the threshold(s).

The threshold definition is in the form: <<Threshold;B2:B20;Min=100;Max=1000>>

Formatting
Use this feature to add cell formatting, such as font, font size, and color. To use this
feature, click the Formatting subtab in LiveView Template Editor. A formatting toolbar
displays on the screen. It allows you to set the appearance of the cells in the template.

NOTE: Formatting changes become visible only after you click outside of the cell that
you change.

To format a cell or range of cells, select the cell(s). When you select a format, the active
cell(s) will be set to the specified format attribute. When a cell becomes active, the
format selections on the toolbar will reflect the selections for that cell. When you select
multiple cells, the format selections will reflect those of the first cell you select.

Then you can format the cell appearance:

• Choose font and font size.
• Choose whether to apply bold, italics, or underline.
• Choose a color for the font (default is black), and for the background of the cells

(default is white).
• Choose the horizontal alignment: flush left, centered, or flush right.
• Choose the vertical alignment: top, center, or bottom.
• If more than one cell is selected, Merge Cells is enabled. Check this box to merge

the selected cells into one large cell.
• In the Data Type drop-down box, select the type of data that will be in the selected

cell(s):
— Text (default); theWrap Text box displays; check this box if you want text to

wrap and stay within the cell.
— Date; In the Format field that displays, type the format you want to use (Excel

formatting is supported):
24-hour format: m/d/yy h:mm:ss
AM/PM format: m/d/yy h:mm:ss AM/PM or m/d/yy hh:mm:ss AM/PM

— Number; In the Decimal Places field that displays, choose the number of
decimal places you want; if desired, check the Use 1000 Separator box to insert
the separator (for example, comma, depending on your regional settings).

• You can resize the row height or column width by dragging row/column header. A
tooltip displays the height or width as you resize it.

Alternatively, right click anywhere in the template to display a context menu that
allows you to insert/remove columns or rows, or to type the column width and row
height.

Save your changes.

See also:

To add data formulas to the Live View template, see Formulas on page 76.

To add data (device names and tag names) to the Live View template, see
Placeholders on page 76.
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To add visual alerts (color changes) when the value of the tag associated with a cell
becomes too high or too low, see Thresholds on page 77
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Set Up ENM on the PowerSCADA Expert Primary Server
You can install the Event Notification Module (ENM) after PowerSCADA Expert and
SQL are installed on the computer. If SQL is not already installed, you must add it
before you install ENM.

Refer to the ENM Installation Guide for information on installing ENM. After it is
installed, refer to the ENM Configuration and Monitoring and Diagnostics help files,
which will be installed also. It is important to note all steps/tabs must be completed in
order for ENM to work correctly. For example, you must configure a filter and schedule,
as they are not optional. Be sure to use the e-mail test function to verify that the e-mail
server is configured correctly.

The ENM configuration page has eight tabs:

Event Sources: Enter the name or IP address of the PSE Alarm Server, then detect
and select the source.

Filters: Choose the source and add a filter. It can be based on tag severity or a wide
range of conditions, such as timestamp.

Recipients: Add the identifying name of the person who will receive the notifications.

Delivery Relays: Configure the method used: either Email, GSM, or SNMP.

Schedules: Configure day of the week and start/end time for notifications.

Subscriptions: Select the source, filter, and delivery from previously configured tabs.
You can also select a test notification and health check notification.

Services: Allows you to stop and start services and see their status.

Maintenance Control: Select alarms to temporarily suspend notifications being sent.
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Set Up the Advanced Reporting and Dashboards Server
The installation medium is located on the same DVD or .ISO as the PowerSCADA
Expert installation, in the Advanced Reporting Module folder.

On the server that you will use for the Advanced Reporting and Dashboards Module,
,install software in the order shown below.

• SQL

• Advanced Reporting Module: Use the PowerSCADA Expert 8.1 with Advanced
Reports and Dashboards installation medium and installation guide.

At this stage of the commissioning procedure, many I/O devices have been added to
thePowerSCADA Expert system. However, in order to obtain Power Quality reports and
Branch Circuit Monitoring reports and hierarchy functionality, these types of devices
must be added again on the Advanced Reporting/Dashboards server. To do this, use
the Management Console application to add and configure these devices.

For information about the Management Console, refer to the Power Monitoring Expert
Installation and Commissioning Guide.

Determine the Device Name and Test the Direct URL for WebReach Dia-
grams

To display the diagram, you need to determine the device name using SQL and test
the URL in a browser.

1. In SQL Server Management Studio, make sure you are using the ION_Network
database.

2. Execute the following query:

SELECT Name FROM dbo.device

3. Find the device name that you want.

4. Open a browser window and enter the following URL to test the diagram display.
Replace [device name] with the name you found in the previous step, and
[servername] with the name of the Power Monitoring Expert server.

http://[servername]/Ion/default.aspx?dgm=OPEN_TEMPLATE_
DIAGRAM&node=[device name]

For example, a real URL would look like:

http://10.168.94.77/Ion/default.aspx?dgm=OPEN_TEMPLATE_
DIAGRAM&node=TVD.7650

5. The device diagram should display in the browser window, and you should be able
to navigate around the diagram, per normal WebReach function.

Determine the Dashboards Slideshow ID to Use In PSE
1. To determine the slideshow GUID, you must have access to the Slide Show

Manager in Power Monitoring Expert.
2. In the Slideshow Manager, select each individual slideshow and click "Share." This

causes each slideshow's GUID to display as shown below.
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Determine the Advanced Reports Report ID to Use In PowerSCADA
Open SQL Management Studio. Create and run the query shown below:

SELECT TOP 1000

[ReportID]

, [DisplayName]

, [SubFolder]

, [Name]

FROM [ION_Network].[dbo].[RPT_Report]

This will display the names and IDs of all the reports that have been configured and
saved. It is possible to have two reports with the same name, but the [SubFolder]
designation will make them unique.

82 © 1990–2016 Schneider Electric All Rights Reserved

7EN02-0382-00 Set Up the Advanced Reporting and Dashboards Server
03/2016



Finish Configuring the PowerSCADA Expert Primary Server
Final configuration of the PowerSCADA Expert primay server involves the following:

• final edits to Citect.ini (add single sign-on settings)
• final edits to Project Menu Configuration
• addition of web diagrams to equipment popups

Configure Single Sign-On (SSO)
Use this feature, which is part of the Application Configuration Utility, to associate a
Citect user with either a PowerSCADA Expert (PowerSCADA) or Power Monitoring
Expert (PME) username/password. When the Citect user is logged in to runtime and
accesses an external application (such as Dashboards), the SSO user password from
PME is used to authenticate with the external application.

We recommend, when you use single sign-on, that you maintain the components on
the same computer or on a secure network. If higher security is needed, use SSL
(https).

NOTICE
LOSS OF SYSTEM CONFIDENTIALITY/INTEGRITY/AVAILABILITY

Ensure that all single sign on information is secured, either on the same computer or
a secure network.

Failure to follow these instructions can result in unauthorized access to, modi-
fication of, and unavailability of the system.

To launch the screen you need, open the Application Configuration Utility: 

Click Start > All Programs > Schneider Electric > PowerSCADA Expert 8.1 with
Advanced and Reporting > Config Tools > Application Config Utility. Click the Security
tab.

The fields are:

• Application: From the drop-down list, choose the application (such as Dashboards,
Basic Reporting, Advanced Reporting, Diagrams, LiveView) for which you want
Citect-to-SSO user mapping.

• Timeout: The time after which the system will stop trying to find a match. If no match
is found, single sign on for this user will not take place.

• Guest User: This feature allows you to create users in PME or PowerSCADA that
will have fewer feature privileges. The guest user does not have an established
Citect account, but will need to have a PME or PowerSCADA account that matches
this username/password.

Check Guest User, then click Edit to launch the Edit User dialog. In the Edit User
dialog, type the SSO user and password that match the username and password of
the PME or PowerSCADA user. For example, you could create a guest user that
only has access to dashboards, and link PME or PowerSCADA users to this
account. Thus, when the PME or PowerSCADA user logs in, they could access
dashboards with this default account.
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• Users: Add/modify the users to have access to the selected application. Use this
area to add users who do need to have a Citect user account.
— Citect User: the Citect username that is requesting authorization.
— SSO User:/SSO Password: The established credentials for this user, either from

PowerSCADA Expert or Power Monitoring Expert.

Single Sign-On (SSO) Calls from a Web Client

PowerSCADA Expert automatically detects calls that are made from a web client. The
calls are sent to an I/O server. For this to work properly, the user needs RPC privileges
for web client access. The default is False. To change this to True, access the user
account through Roles in the Citect Project Editor. (System > Roles). Change "Allow
RPC" to TRUE.

Configure One-Time Password (Two-Factor Authentication)
Two-factor authentication (2FA) requires users to provide two pieces of proof of
identity, such as a password and one other component. This feature allows you to add
an additional layer of protection when user credentials are required (for example, at
login and shutdown).

PowerSCADA Expert uses a one-time password (OTP) to accomplish two-factor
authentication.

OTP is implemented in PowerSCADA Expert using a small USB-key device called a
YubiKey. The YubiKey device is designed to fit on a key ring or attached to a badge. It
must be plugged into the client machine when the user authenticates. There are
multiple models of YubiKeys available. Included is one model with Near Field
Communication (NFC) capability in the event that USB ports cannot be used.

Select the YubiKey

YubiKeys are not shipped with PowerSCADA Expert. Instead, you must buy them from
a third-party vendor, such as Amazon. The following table describes the various
YubiKey models that are compatible with PowerSCADA Expert.

Model Number Description

YubiKey Standard Standard YubiKey, suitable for most deployments

YubiKey Nano
Small form factor, designed to remain inserted in the USB port. Suitable for
use in clients with a dedicated single user account.

YubiKey Edge
Similar to Standard, includes advanced features not useful for
PowerSCADAExpert. Recommend YubiKey Standard instead. May not
support auto configuration.

YubiKey Edge-N
Similar to Nano, includes advanced features not useful for PowerSCADA
Expert. Recommend YubiKey Nano instead. May not support auto
configuration.

YubiKey NEO
Similar to Standard, includes NFC capability. Note: NFC setup requires
Yubico personalization tool (free) and a compatible NFC reader.

YubiCo NEO-N
Similar to Nano, includes NFC capability.

Note: NFC setup requires Yubico personalization tool (free) and a
compatible NFC reader.

For more information about these keys, see http://www. yubico.com.

Deployment Guidelines

Keep in mind these points when you are ordering or using a YubiKey.
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• You must set "Allow RPC" to TRUE for all roles that are using YubiKey.

• YubiKey is compatible with all thick clients and web clients.
• YubiKey requires access to a USB port at each client (or must include NFC

capability).
• While technically compliant, NFC has not been validated for use with PowerSCADA

Expert.
• Each PowerSCADA Expert I/O server must have Application Services (Core

Service Host) running.
• Multiple I/O servers may reside on a physical machine. In this case, only one

instance of Application Services resides on the machine.
• Yubikey must be configured and synchronized across all I/O Servers (this includes

redundant pairs and distributed systems).
• YubiKey is enabled on each client independently.
• It is possible to configure YubiKey on one machine, export the configuration for all

users, and import the configuration to all remaining machines.
• It is not necessary to re-program YubiKey when changing passwords. The YubiKey

constantly changes the OTP (as it is only valid once); so it is not susceptible to
replay attacks.

• YubiKey is authenticated against all physical servers that contain at least one I/O
server. All physical servers must successfully authenticate the OTP for success. If a
single physical server does not authenticate (due to misconfiguration, etc), the user
will not be able to log in.

• If a physical machine (with an I/O Server) is not available, it is not included in the
authentication scheme (this means that, if a primary server is down, the secondary
can still successfully authenticate the OTP).

• If no physical servers (with I/O Servers) are available, the user will not be able to
log in on clients that have YubiKey enabled.

Autoconfigure the YubiKey
To avoid the lengthier process of programming the key, in most cases you can choose
to autoconfigure it.

NOTES:
• This procedure requires that you have a USB port on your computer. It will not work

for virtual machines.
• An option for computers without USB ports is to autoconfigure on a local

workstation, then export the settings to a shared drive and import the settings onto
the computer where you need them. (See Import and Export One-Time Password
Settings on page 88, below.)

• You can only have one YubiKey inserted at a time.
• If Autoconfigure will not work, and you must manually program the YubiKey, see

Program the YubiKey on page 86 for instructions.

To autoconfigure, follow these steps:

1. Insert the YubiKey into the USB port of the computer.
2. In the Application Configuration Utility, navigate to the One-Time Password screen

from the Security menu:
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3. Click Assign Key.

The grayed-out fields become live.
4. In the User field, type the PowerSCADA Expert username to which you want to

assign the YubiKey.

5. Click Autoconfigure YubiKey (in the lower half of the screen). You see this
message:

This message tells you that all settings on the key will be erased, including any key
assignments.

6. To continue, click Yes. The key will receive a new secret key.

7. Click Accept.

Program the YubiKey
If you cannot autoconfigure, use this procedure. After you obtain the YubiKey from a
third-party vendor, (such as Amazon), you need to download the YubiKey
Personalization Tool from the Yubico website (www.yubico.com; click Products >
Services & Software > Personalization Tools > Download Yubikey Configuration
Tools).

1. Download and install the YubiKey Personalization Tool.
2. Launch the tool, and this screen displays:
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3. Insert the YubiKey into a USB port of your computer. Click the Yubico OTP Mode
link. At the next screen, click Advanced.

This screen displays:

If you want to use both of the key's configuration slots, download the YubiKey
documentation, found under the Support tab of the Yubico website.

To configure a single slot, follow these steps:

4. Click the checkbox for the slot you want to configure.

5. Under Yubico OTP Parameters, check Public Identity. Click Generate.

6. Leave the Public Identity Length at its default, 6.

7. Check Private Identity. Click Generate.

8. Click Generate beside Secret Key.

9. Make a note of the secret key that displays, including all characters and spaces.
You will need it when you add the key to the Application Configuration Tool.
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10. Click Write Configuration.

11. Click the Settings tab. This screen appears:

Enter the following information:

1. Under Output Settings, do not enable any of the tab buttons (when enabled, a
button turns blue). Click Enter to enable it.

This causes a return and an "OK" to automatically occur when you press the
Yubikey as part of login in PowerSCADA Expert.

2. Ignore the remaining settings. Press Update Settings at the bottom right of the
screen.

The key is programmed. Follow the next procedure to manually configure it at the
PowerSCADA Expert computer:

1. Access the One-Time Password screen.
2. Click Assign Key.

The fields on the lower half of the screen become live.
3. User: Type the user name that you are adding. This should be a Citect user.

4. Serial Number: Type the number that is printed on the underside of the key.

5. Secret Key: Enter the Secret Key from the YubiKey Personalization Tool (created
above). Enter the secret key exactly as it was created, including all spaces. After
you enter it, the key will be encrypted and will display as bullets (••••) in the future.

6. Press the button on the top of the YubiKey.

7. Yubikey String: This field is populated when you press the button in step 6.

8. Click Accept.
9. Repeat the steps above for any additional keys.

Import and Export One-Time Password Settings
To copy and use one-time password settings on multiple server computers, use this
procedure.
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NOTE: When you import password settings into another server, you will overwrite any
password settings that already exist there. You are not simply adding the new
password settings to the existing ones.

1. On the One-time Password screen, create the password settings that you want to
use.

2. Click Export. A file named ExportedOTPConfiguration.xml is generated. You can
rename it if you wish. Save it where you can access it from other servers, or place it
on a jump drive.

3. From a server to which you want to import the password settings, click Import. You
are prompted for a location.

4. Browse to the location where you placed the .xml file. Click Open and accept the
.xml file.

Disabling YubiKeys
To "disable" a YubiKey, use the Citect Parameter that you created for the YubiKey (see
Configure One-Time Password (Two-Factor Authentication) on page 84). Scroll to the
parameter for the Yubikey. Change the Value from true to false. Click Replace, then
compile the project.

Final Edits to the Citect.ini File
Final edits to the Citect.ini file include the following:

Add Single Sign-On Settings to Citect.ini on page 90

Add the One-Time Password Parameter on page 91

Add the WebReach Server Parameter on page 91

Set Up Audible Alarms
You can use a variety of Windows wave files for audible alarms. To enable this feature,
follow these steps:

1. Define the alarm sound to be used and the repeat interval for each priority in the
alarm you want to be audible. Enter the following information, either in the project
parameters (Citect Project Editor > System > Parameters) or in the Citect.ini file:

a. [Alarm]
b. Sound<priority>=<wave file name>
c. Sound<priority>Interval=<repeating interval in milliseconds>
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If the device is added through the I/O Device Manager, the alarm priority will be 1,
2, and 3 for _PLSALM_HIGH, _PLSALM_MEDIUM, _PLSALM_LOW alarms
respectively.

The user can define specific wave files for the sounds. We support the following
Windows operating system sounds:

SystemAsterisk

SystemExclamation

SystemQuestion

SystemDefault

SystemHand

SystemExit

SystemStart

2. After alarms are set up: When an alarm occurs, its specified alarm sound will play
continually according to the specified interval. The alarm sound will stop when
either:
— the user clicks Silence Alarm on the alarm page
— the alarm is acknowledged

Add Single Sign-On Settings to Citect.ini
Open the Citect.INI file. (typically in C:\ProgramData\Schneider Electric\PowerSCADA
Expert\v8.1\Config) In this file, you will add the following SSO values (if they are not
already there).

[SSO]

Hostname=

SupportsVisitorDashboard=

RemoteCallHandlerServer=

RemoteCallHandlerCluster=

[Application]Area=

[Application]PrivLevel=

Complete each parameter with the value specified below. Then save the modified
citect.ini file:

• Hostname: The name or ip address of the computer that hosts Power Monitoring
Expert.

• SupportsVisitorDashboard: Indicates if the Power Monitoring Expert system
supports automated visitor login. Set this to 1 (which means true) as Power
Monitoring Expert v8.0 supports it. (Earlier versions did not support this option.)

• RemoteCallHandlerServer: This parameter supports SSO with the use of web
clients. The value must be an IO server configured in your project

• RemoteCallHandlerCluster: Like the above parameter, this supports SSO with the
use of web clients. Its value must be a cluster name associated with the above
IOserver.

• [Application]Area: Allows the use of the “area” field associated with Citect users. It
can be configured on a per application level including: PSEreporting, Reporting
(PME), WebReach, and Dashboards, and provides the ability to limit the use of
SSO operations to specific areas.

• [Application]Privlevel: Allows the use of the “privilege level” field associated with
Citect users: It can be configured on a per-application level including:
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PSEreporting, Reporting (PME), WebReach, Dashboards, and provides the ability
to limit use of SSO operations to specific privileges.

Add the One-Time Password Parameter
You need to add the parameter that allows PowerSCADA Expert to communicate with
the YubiKey. You can do this before or after you configure the YubiKey.

From the Citect Project Editor, click System > Parameters. At the Parameters screen,
type the following:

• Section Name: Security
• Name: OneTimePasswordRequired
• Value: true

Click Add, then compile the project to add the parameter.

To be able to use YubiKey in PowerSCADA Expert, you must set "Allow RPC" to TRUE
for all roles that include users with assigned YubiKeys. The default for PowerSCADA
Expert is False. To change this to True, access the user account through Roles in the
Citect Project Editor. (System > Roles). Change "Allow RPC" to TRUE.

Add the WebReach Server Parameter
To add PME server properties into the Citect.ini file:

1. Open the Citect Project Editor.
2. Launch the Computer Setup Editor:

Click Tools > Computer Setup Editor.

3. Add a new Section named “Applications” and a parameter named
“WebReachServer” with a value of either a servername or the ipaddress of the PME
server.

4. Click Add and save the Citect.ini

Time Zone Settings
To interact with devices located in different time zones, the system converts any
alarm/waveform timestamp as well as the actual time sent within the Set Time
command from / to the local time zone. In order to take into account daylight savings
properly, the Windows time zones database is used. Thus, time zone names must be
taken directly from this database (case-insensitive), otherwise the system will default to
using the I/O server’s local time zone. The Windows time zone database is located in
the Windows registry in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\Time Zones\. Examples of time zone names are

• AUS Central Standard Time
• China Standard Time
• Pacific Standard Time (Mexico)

Time zones for remote devices can be specified on two levels:

1. Use section [ProtocolName.ClusterName.PortName.IODeviceName] to specify the
time zone for a particular device, e.g.:

[PLOGIC870.Cluster1.PM870_Port.PM870_Device1]

Timezone = Singapore Standard Time

2. Use general section [POWERLOGICCORE] to specify the time zone for all devices,
e.g.:
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[POWERLOGICCORE]

Timezone = Mountain Standard Time

The device-specific time zone specification takes precedence. In other words, if both of
the above examples are present in the Citect.ini file, the PM870_Device1 would be
located in “Singapore Standard Time” time zone, and all the other I/O devices in the
project would be located in “Mountain Standard Time” time zone.

If there is no time zone specification (or if it does not match the time zone from
Windows database), the device would be in the same time zone as the machine where
the I/O Server is running; thus, no time conversion will be done.

If only the first of the above examples is present within the Citect.ini file, the PM870_
Device1 would be located in “Singapore Standard Time,” and all the other devices use
the current local time zone.

Final Edits to Project Menu Configuration
Final edits to Project Menu Configuration include:

Add Menu Items for LiveView Data Tables on page 92

Finish Advanced Reports Page Menu Items on page 93

Finish Dashboards Page Menu Items on page 93

Finish WebDiagrams Page Menu Items on page 93

Add Menu Items for LiveView Data Tables
Using the names of real-time data table views that you saved earlier (see Create and
Save Real-Time Data Views in LiveView on page 75), you need to add a Menu
Configuration item for each saved view.

In the Citect Project Editor, click System > Menu Configuration.

In the following example, there is a saved view named "BasicReadingsSummary," and
"localhost" is used to indicate that LiveView is running on the PowerSCADA server.
Use the PLS_LiveViewDsp cicode function as shown here in order to display your
saved view in the operator HMI.

Add the corresponding information for each saved real-time data table view you wish
to see in the HMI.
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Finish Advanced Reports Page Menu Items
Revisit each project menu configuration item earlier created for displaying Advanced
Reports pages. Do not update the menu item earlier created for the Advanced Reports
Root Page.

For each item, update the menu command with the respective ReportID, which was
earlier determined in this section: Determine the Advanced Reports Report ID to Use In
PowerSCADA on page 82.

Finish Dashboards Page Menu Items
Revisit each project menu configuration item earlier created for displaying Dashboard
slideshow pages.

For each item, update the menu command with the respective slideshow GUID, which
was earlier determined in this topic: Determine the Dashboards Slideshow ID to Use In
PSE on page 81.

Finish WebDiagrams Page Menu Items
Revisit each project menu configuration item earlier created for displaying
WebDiagram pages.

For each item update the menu command with the respective DeviceName determined
in this topic: Determine the Device Name and Test the Direct URL for WebReach
Diagrams on page 81.
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Add Web Diagrams to Equipment Popups
To launch the diagram from a meter genie equipment page, follow the steps below.

This method only works when Power Monitoring Expert device names are identical to
PowerSCADA Expert equipment names.

1. Open the PowerSCADA Expert Graphics Builder and navigate to the page on
which you want to insert the meter genie.

2. Click Edit > Paste Genie.

3. Under Library, click pls_meter and select the desired meter genie.

4. Near the bottom of the page, locate the “Events” fields.

5. In the "Details Pop Up" field, enter the PLS_WebReachPopup cicode method. Your
Genie Properties dialog should look similar to this:

NOTE: Unlike the other two button types (from a menu or popup page), you do not
specify the sDevice name; instead you pass #EQUIP. This value is a property of the
genie. This only works when the PowerSCADA Expertequipment anme is the same as
the Power Monitoring Expert group.devicename.
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The final result is an equipment popup that contains a button that looks like this:

To test the WebReach URL, try to following:

• Enter the URL of the diagram directly into a browser window; verify that it launches.
The URL is: http://[servername]/ION/default.aspx?dgm=OPEN_TEMPLATE_
DIAGRAM&node=[device name]

• If this does not work, verify that the WebReachServer is correct in your citect.ini, and
the diagram appears correctly in WebReach.
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Compile the Project
After you install the software and create the project—along with clusters, network
addresses, and servers—perform your first system compile. You will also do this
periodically during system setup.

It is always a good idea to "pack" before you compile. From the Citect Project Editor,
click File > Pack. Then, from the Citect Project Editor, click File > Compile. Correct any
errors and note any warnings.
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Back Up the PowerSCADA Expert Primary Server Con-
figuration

When you need to back up your PowerSCADA Expert project and the ENM files, use
these instructions. (To back up the Profile Editor, use the Export feature on the Projects
tab.)

Back Up the PowerSCADA Expert Project
Use this feature to back up a Citect project file.

1. From the Citect Explorer, click Tools > Backup.
2. At the Backup Project window, select the project you want to back up

3. Browse to the location where you want to store the backup file.

4. In the Options box, check “Save configuration files.” This saves the citect.ini file.
Also check "Save sub-directories" and "Use Compression."

5. Click OK.

The backup .CTZ file is written to the location that you choose during backup. This is a
Citect Zip file; you can open it with WinZip.

Back Up ENM
By default, ENM runs a database backup daily as part of SQL scripts that run in a
Windows scheduled task. If you need to change the directory for database backup, see
the DBMaintenance directory on the ENM computer.

Back Up One-Time Password
To copy and use one-time password settings on multiple server computers, do the
following:

In the Application Configuration Utility:

1. On the One-time Password screen, create the password settings that you want to
use.

2. Click Export. A file named ExportedOTPConfiguration.xml is generated. You can
rename it if you wish. Save it where you can access it from other servers, or place it
on a jump drive.

Back Up One-Line Engine Encryption
In the Application Configuration Utility, from the Applications > One Line Engine
screen, click Export Key. A Save As window displays, allowing you to browse to the
preferred location.

Save the .aes file to a secure location, such as a secure network drive or a flash drive.
Also, back up the AdvOneLine.INI file. You will copy this to the PowerSCADA Expert
secondary server after accessing the .aes file from that server during the restore
process.
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NOTICE
LOSS OF SYSTEM CONFIDENTIALITY/INTEGRITY/AVAILABILITY

Do not save the .aes encryption file to the local computer. Always export it to a
secure site, such as a secure network or to the target computer.

Failure to follow these instructions can result in unauthorized access to, modi-
fication of, and unavailability of the system.

Back Up Application Configuration Utility Settings
Browse to the PowerSCADA Expert installation directory, AppServices\bin directory
(typically found in: C:\Program Files (x86)\Schneider Electric\PowerSCADA
Expert\v8.0\Applications\AppServices\bin).

Copy the Configuration.xml file.

You will paste this file to the same location on the secondary PowerSCADA Expert
server during the restore process.
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Install and Configure the PowerSCADA Expert Secondary
Server

Complete these tasks to configure the PowerSCADA Expert secondary server:

• Restore the PowerSCADA Expert project
• Restore the ENM configuration

— Restore the ENM database earlier saved in the backup procedure.
• Import the one-time password
• Import the Advanced One-Line .aes encryption file.
• Re-enter SSO passwords in the Application Configuration Utility (see Configure

Single Sign-On (SSO) on page 83 for help in using the Application Configuration
Utility).

• Re-enter the Citect Data Platform password in the Application Configuration Utility
(see Citect Data Platform on page 69 for help).

• Re-enter the Advanced One-Line password in the Application Configuration Utility
(see Configure One-Time Password (Two-Factor Authentication) on page 84 for
help).)

Restore the PowerSCADA Expert Project
To restore the project, follow these steps:

1. From the Citect Explorer, click Tools > Restore.
2. In the Restore from box, browse to the location of the file you will use to restore.

3. In the Options box, check Configuration files to restore backed up INI files.The sub-
directories included in the earlier backup will be listed under the "Select Sub-
Directories to Restore" box. Restore all sub-directories.

4. Click OK.

Restore ENM Configuration
After you have Installed ENM (see Set Up ENM on the PowerSCADA Expert Primary
Server on page 80), follow these steps to restore it to thePowerSCADA Expert
secondary server.

1. You must first have backed up ENM, which is done during a normal PowerSCADA
Expert backup (see Back Up ENM on page 97).

2. Using SQL Management Studio, locate the PLES_APM database (the
ENM database), that you backed up earlier. The screen capture below shows the
file location.

3. In SQL Management Studio, open the PLES_APM database and view the dbo.AP_
OPC_SERVERS table.

4. Ensure the the proper HOST_COMPUTER values exist for the given SERVER_
NAME items.

"LOCALHOST" or the "127.0.0.1" address should be used here; but if a non-
loopback network IP address was used in the initial configuration of ENM on the
PSE primary server, update the field here to contain the accurate hostname/ip
address of the PSE secondary server on which this procedure is being performed.
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Import the One-Time Password
When you import password settings into another server, you will overwrite any
password settings that already exist there. You are not simply adding the new
password settings to the existing ones.

In the Application Configuration Utility:

1. From the One-Time Password screen, click Import. You are prompted for a location.
2. Browse to the location where you earlier placed the .xml file. Click Open and accept

the .xml file.

Import the Advanced One-Line AES Encryption File
In the Application Configuration Utility, from the Applications > One Line Engine screen
click the "Import Key" button to access the .aes file. After you access the .aes file copy
the AdvOneLine.INI file to the PowerSCADA Secondary server. You will now be able to
access and use it.
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Install and Deploy the PowerSCADA Expert Web Client
(optional)

To install and deploy a remote PowerSCADA Expertweb client, follow the steps
outlined in the Vijeo Citect 2015 Web Client Guide.
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System Startup and Validation Checks
To test and validate the project that you have created, perform these tasks:

• Test two-factor authentication (see Log In With a Programmed YubiKey and One-
Time Password on page 117).

• Test the web client: Open the web client and verify that links are working properly.
• Test single sign-on to Dashboards, Advanced Reports, and Web Diagrams.
• Test the Advanced One-Line
• Verify That I/O Devices are Communicating on page 102

Verify That I/O Devices are Communicating
After the system is configured and communicating in runtime mode, you need to verify
that all devices are communicating correctly. All devices that are not communicating
should trigger "Communication Failure" alarms, which can be seen in the active alarm
log screen. For instructions on adding this screen to the project, see Add Alarm Pages
on page 63Add Alarm Pages on page 63On the Menu Configuration page, use
PLSDspShowAlarm(0) as the menu item Menu Command.

Use one of the following methods to test communication.

View the graphics pages.

1. Create a graphics page containing an appropriate genie selected from the pls_
meter library, found in the pls_include project.

2. Assign the selected genie to the specific device needed to verify communications.

3. Save the page and compile the project.

4. In runtime mode, double-click the genie to open the genie pop-up. Verify that the
updated readings displayed by the genie match the actual values on the meter
itself. If the readings match, you have verified the device is communicating.

The following illustration shows a genie and its related genie pop-up.
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Use the Tag Viewer to learn the status of all project tags.

During runtime, open one of the pages that displays real time tag values. The example
below is PLSTagView. Compare the values displayed on the TagViewer page to actual
values displayed on the meter itself. If the compared values match then you have
verified communications with that device.

See also:

Add the Tag Viewer Page Menu Item on page 63 and

Use the Tag Viewer on page 107

Use the One-Line Configuration Utility to verify that devices are connected and
animations are working.

The electrical system must be in a non-critical state so that the breakers being used will
not cause any adverse effects (such as putting a person’s safety at risk or affecting a
process). Breaker genies should be able to remotely operate the breaker.
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DANGER
HAZARD OF ELECTRIC SHOCK, EXPLOSION, OR ARC FLASH

• Do not rely solely on the display of the genie on the one-line.
• Use this procedure only during development, and not on a live deployed sys-

tem.
• Before energizing or de-energizing any equipment from this software, verify that

all personnel are at a safe distance from all energized equipment.
• Before testing, verify that the proper lock out/tag out procedure is followed, to

ensure that the equipment is in an electrically safe condition.
• Ensure that all safety regulations and procedures have been followed before

you work on the equipment.

Failure to follow these instructions will result in death or serious injury.

In the Graphics Builder, create a one-line diagram with breaker genies that use the
breakers you want to verify. Use the proper logic and passwords to configure the one-
line on the diagram. After the diagram is successfully created, open the graphic page
in runtime mode.

The breaker genie status indicator should mirror the current breaker state. Also, the
busbar color should accurately reflect the electrical state of the conductors connected
to the breaker.

The following illustrates the appearance of the one-line drawing with breakers first
open and then closed. Note the color change, from black to green (energized), and the
position and current changes on the breakers.
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See also:

Review One-Line Page Configurations on page 46

Communications Losses

When you bring your system on line, if you find that PowerSCADA Expert has lost
communications with a device, check the following:

• Verify that the physical connection is correct and secure.
• Verify the IP address.
• Verify the Modbus address.
• Check the statusRegister, statusRegistersCount, and statusRegisterType (see for

details)
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Use the I/O Device Settings Viewer
The Diagnostics page provides a quick view of the I/O device INI settings for all
protocols, clusters, servers, ports, and devices. Use this information as the first step in
troubleshooting device/communication issues in your system.

When you first click the Diagnostics tab, a short description and help link display on the
right-hand side. The basic steps you follow are below. See the section after the steps
for the logic behind how data displays.

1. To begin viewing data, click the Diagnostics link on the left. The I/O Device Settings
link displays. Click that link. Notice that the right-hand pane displays a link for the
project name.

2. Click the Project Name drop-down box and choose the project for which you want
to view data. PowerSCADA Expert loads the server information for this project. Note
that you could have multiple servers: I/O, alarm, and trend.

3. From the View pane, click a cluster and then a server.

4. (I/O servers only): From the Protocol column, choose a protocol and then the port
and device.

5. View the data for that device:
— The top row of the Settings are a "breadcrumb," showing the device information

from cluster to device.
— The second row, just above Effective Settings, displays details about the device,

equipment name, number of tags, address, priority, memory mode and startup
mode.

— The remaining sections display information only if there have been changes
made to the default settings.

Data Selection Logic

Depending on the server type that you select, the Settings on the right display with
different information.

All three server types display settings that include:

• Default Settings: the device default before any changes have been made; displays
above the Effective Settings section.

• Effective Settings: the current settings, including any changes made, combining
changes from the protocol, port, and device. In all cases, port changes will override
protocol changes, and device changes will override port changes.

• Protocol Settings/Port Settings/Device Settings: If there are any overrides to the
default settings, they display here.

I/O servers alone display a separate column: When you select an I/O server, the
Protocol column displays beside it. You will select protocol, port and device.

Data is retrieved in this manner: protocol settings are retrieved from the Param.dbf file
and then from the citect.ini file. These two lists of settings are merged. If there are
duplicate settings, the citect.ini file changes take precedence. Finally, device settings
are retrieved and merged. If there are duplicate settings, the device settings take
precedence.

For example, for a given device:

The Protocol Setting for CacheRefreshTime = 2000.

The Port Setting = 1000.
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There is no additional Device Setting to override the other settings.

The Effective Setting uses the CacheRefreshTime of 1000 from the Port Setting.

Use the Tag Viewer
Use the tag viewer to learn the status of all of your project tags. This can provide
information that you need to troubleshoot the project while you are developing it.

You can filter the tags that you view by individual equipment included in the project.
You can also filter on strings that are part of the tag description or tag name. The tag
viewer will work in all supported Citect screen resolutions.

To view tags:

Click the tab for the page that was used when setting up the tag viewer, then select the
tag viewer. The viewer displays in a screen similar to this:

Note the following features:

• Filter by equipment: The left-hand pane gives you the option to filter by equipment
name. Most equipment is grouped by voltage level. You can select one equipment
node, and you will view the tags for that equipment.

• Filter by tag: In the upper right corner of the screen, type the tag name. You can
type a string, such as "power factor," and you will retrieve a list of tags that have
"power factor" in their tag description or tag name.

NOTE: Any time you display a tag, you add to the dynamic point count. See
"Dynamic-point Count Licensing" in the citectscada.chm help file (default location:
Program Files > Schneider Electric >PowerSCADA Expert > v8.0, SR1 > bin) for
more information about point counts.

The viewer includes the following columns:

• Tag Description/Tag Name: the description and name used when the equipment
was added to PowerSCADA Expert.

• Value/Timestamp: The real-time value that was read at the date/time shown.
• Quality: The data quality (for example, Good or Bad) of the tag from Citect.
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Use the Previous and Next links at the bottom right of the page to scroll through
multiple pages.

When Alarms do not Display Correctly
Alarms may display incorrectly for a variety of reasons. The following table lists some
common issues and resolutions.

Issue Cause Resolution

Alarm Log and Event Log
do not display any data.

If there are two alarm
servers, primary and
redundant (standby), they
may be synchronizing. This
causes data to display
slowly.

Data will display; but it could take several minutes.

Alarms display in Alarm
Log, but not in Event Log or
Banner

Themissing alarm(s) were
triggered while the runtime
graphics page was not
running.

These alarms will only display in the Alarm Log
unless they are triggered again while the runtime
graphics page is running. This will only affect
alarms that were triggered before the runtime
screen was running.

PC-based and onboard
alarms do not appear or
disappear as expected.

This is due to the difference between way the two alarm types are handled:

When an alarm is enabled, the system processes alarms for that tag. If the alarm
is disabled, the system cannot process alarms for that tag.

For the PC-Based alarm, the condition for this is, for example, IA > 80; if the tag
value for IA is > 80, the appearance will show. The tag is constantly scanned, so
the condition triggers the alarm once it is enabled.

For the Onboard alarm, the condition for this is a digital tag, which is set by the
driver when a new alarm record on the device is read. If the alarm was disabled,
the driver cannot set the digital tag. When the alarm is enabled, nothing happens
because the alarm was already "processed" by the driver and will never get
reprocessed.

Thus, there is no resolution.

The number of alarms that
display is fewer than the
limit set by Alarm Summary
length parameter.

This happens when the
number of alarms exceeds
1000 and the system has
multiple clusters.

Use one or more of these procedures:

Set alarm filtering in the alarm viewer to reduce the
number of alarms that can display.

Only support a one-cluster system.

If a multiple-cluster system is necessary, display a
separate alarm page for each cluster.

Cannot filter on categories
for alarms.

The new categories do not
display in the list when you
want to select them.

Use Custom Filter 8 instead. Currently, it is the
only means available for adding custom filtering to
alarms.

Page Down button causes
an empty page to display.

The last alarm was on the
previous page. When there
are nomore alarms,
pressing Page Down
displays a blank page.

Click Page Up to return to the previous page (and
the last alarms for the system).
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Use McAfee White Listing
NOTE: The use of McAfee Application Control for whitelisting is optional.

McAfee Application Control (Application Control) is a dynamic whitelisting program that
is used to prevent block unauthorized applications from running on your systems. The
installation files for the software are included on the PowerSCADA Expert disk, but you
must purchase the license separately.

Install Application Control on the PowerSCADA Expert primary and secondary servers,
as well as the Advanced Reports and Dashboards server. For detailed information
about installing Application Control on each server, see the McAfee Installation Guide
located on the PowerSCADA Expert installation disk (McAfee Embedded Control >
Documents > Installation-Guide-v6.2.0).

NOTE: Allow the install to add a desktop shortcut; you need it for all interaction with
Application Control. Also, before you run Application Control, make sure that you have
installed all other software that you want on the computer.

To begin using Application Control, right click the desktop icon and select the Run As
Administrator option.

First, you need to create and solidify the whitelist. To do this:

1. Invoke the sadmin command line as an administrator and type the command
sadmin solidify.
This process can take some time to complete. When it is complete. you see a line
telling you total files scanned and the number that are "solidified."

2. Verify the whitelist with the command sadmin status.

Verify that the whitelist status of drives or volumes is solidified.

3. When this is complete, you need to enable the enforcement of the whitelist: type the
command sadmin enable.

4. Add updaters: Updaters are components for which you provide permission to
update the system. Any program or script that will be able to update the system
must be configured as an updater. To add an updater, enter on the command line:

sadmin updaters add <xxx>

where xxx is the name of the component

For a complete discussion of updaters, see "Using Updaters" in the McAfee Product
Guide (on the PowerSCADA Expert installation disk, see McAfee Embedded
Control > Documents > Product-Guide-v6.2.0)

When running in Enabled mode, Application Control protection can prevent a
legitimate application from executing (if the required rules are not defined). Application
Control tracks all such failed attempts made by authorized executable to modify
protected files or run other executable files.

You can review information for failed attempts to identify updater rules to allow
legitimate applications to run successfully. To do this:

1. Enter the command sadmin dia
2. To add the suggested updaters to the authorized list, use the command sadmin

diag fix.

When you deploy Application Control to protect a system, it scans the system and
creates a whitelist of all executable binaries and scripts present on the system. The
whitelist also includes hidden files and folders.
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The whitelist lists all authorized files and determines trusted or known files. In Enabled
mode, only files that are present in the whitelist are allowed to execute. All files in the
whitelist are protected; you cannot change or delete them. An executable binary or
script that is not in the whitelist is said to be "unauthorized," and it is prevented from
running.

You can also use Application Control to write protect files, directories, drives or registry
entries. Additionally, you can use it to Read Protect Files, Directories, or Drives. For
more information about these applications, see the Product Guide.
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Install and Configure the PowerSCADA Anywhere Server
PowerSCADA Anywhere is a rebranded name for Citect Anywhere. The term
PowerSCADA Anywhere will appear only in the end user-facing web browser, at the
login screen and the launch screen. Everything that is not end user-facing will be
referred to as Citect Anywhere, including the installer, the configuration tool, and
various file paths.

PowerSCADA Anywhere allows a remote desktop session via a web browser to the
PowerSCADA server. It is accessible only in the PowerSCADA runtime mode.

To use PowerSCADA Anywhere, you must first install the PowerSCADA Anywhere
Server (required).

On the PowerSCADA Anywhere server machine, you must install PowerSCADA
Anywhere server software, in addition to installing a PowerSCADA Expert Control
Client. For the PowerSCADA Expert Control Client client, run the PowerSCADA Expert
install; select the control client-only installation. This installation requires a floating
license. It must be on one of these operating systems:

• Windows Server 2008 R2 SP1 Standard, Enterprise (64-bit)
• Windows Server 2012 Standard

For detailed instructions on installing and using the PowerSCADA Anywhere Server,
see the following documents, which are located in the PowerSCADA Anywhere
Installer folder:

• PowerSCADA Anywhere Quick Start Guide.pdf
• PowerSCADA Anywhere Installation and Configuration Guide.pdf

Citect Anywhere Server: Installation and Configuration
1. On the machine where the PowerSCADA Anywhere server is installed, launch the

installer from the PowerSCADA Anywhere installation folder: double-click
setup.exe.

2. Select the Citect Anywhere server option.

3. Accept the license agreement and click Next on each screen of the installation. If
there is a pre-requisite missing, it will be installed for you.
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4. When installation is complete, you see a confirmation screen. Click Finish to close
the install.

Post-Installation Configuration
5. Configure Remote Desktop settings to allow remote access:

a. From the Control Panel, open the System Properties window and click the
Remote tab:

b. Check "Allow Remote Assistance connections to this computer."
c. Click the "Allow connections from computers running any version of Remote

Desktop (less secure)."
d. Click "Select Users" to begin adding user accounts to the Remote Desktop

Users group.
6. Access to the client type is granted through two special Windows user groups

created by the installer on the computer where the Citect Anywhere Server is
installed. You must add users to the VJCAControl and VJCAView groups manually
via Administrative Tools > Computer Management:
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7. Ensure that the Citect Anywhere service is started. To confirm this, use the
ServerConfiguration for Citect Anywhere:

If the server is stopped, click "Start Server."

Connect to PowerSCADA Anywhere
The following browsers are supported by PowerSCADA Anywhere:

• Internet Explorer 10 and 11
• Microsoft Edge
• Google Chrome 33
• Safari 8 on Apple iOS

Connect to a PowerSCADA anywhere Server by navigating to the following web
address in a supported browser:

http://<VJCA Server Node Name or IP address>:8080/

The logon screen appears.
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Log in with Windows user credentials from the Citect Anywhere server. This user
needs to belong to the VjcaView or VjcaControl group on the Citect Anywhere server.
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Install and Configure the Tofino Firewall
NOTE: The use of Tofino firewall is optional in PowerSCADA Expert.

The Schneider Electric Tofino is an industrial firewall designed for use in industrial
control system networks. The firewall offers deep packet inspection of Modbus TCP,
allowing restriction at the Modbus command level as defined by the network designer.
It is highly configurable using software called Connexium Tofino Configurator
(included with Tofino purchase). The software allows a user to define entire networks,
referred to as projects, which can have multiple Tofino firewalls protecting a myriad of
devices (referred to as Assets) at different points in the network.

The setup steps are:

1. Install the Tofino Configurator and create a project.
2. Add all the Tofino devices to your network.

3. Add all of the other devices on the network.

You configure the rules for the network that define the traffic that can pass through
which firewall.

We recommend that you begin with the firewalls in test mode so you can see what
would have been blocked and make adjustments accordingly. The firewall
configurations should be then loaded onto a USB drive that is used to upload the
configuration to each firewall.

Detailed information about the setup and configuration of the Tofino architecture is
provided in the ConneXium TCSEFEA User Manual V1.You should not use this firewall
as an “edge” device, bridging the Control Network with public networks.

The following is an example architecture that can serve as reference for how one of the
networks might be constructed. It is a small network that can be scaled out to fit a much
larger system.
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Log In With a Programmed YubiKey and One-Time Pass-
word

After the key is programmed and associated with a user in PowerSCADA Expert, and
you have enabled YubiKey usage, the user will use the key to log in to the system. To
log in:

1. Insert the programmed YubiKey into a USB port of the PowerSCADA Expert server.
2. Launch PowerSCADA Expert Runtime, or access runtime via a remote web client.

3. Run the project you want to view.

4. In the upper right corner of the Startup screen, click Login.

You see the Citect login screen.

5. Enter your name and password. Click OK.

The One-time Password screen appears.

6. Press the button on the YubiKey.

The one-time password is generated. The key and software communicate behind the
scenes to verify the uniqueness of the one-time password and to click OK.

You can start using runtime screens.
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Work in the Runtime Environment
Launch Runtime

To launch the runtime environment, do one of the following:

• Click Start < Programs > Schneider Electric > PowerSCADA Expert 8.1 >
PowerSCADA Expert Runtime.

• From any of the Citect windows, click File > Run.

Close Runtime
To close the runtime environment, do one of the following:

• Click the "X" in the upper right corner of the screen. Then enter a valid user name
and password. (It is important that you have defined at least one new user in your
project.)

• From the computer taskbar, click the Runtime manager:

View the Interface
The runtime environment page includes a variety of tabs. If your page is created based
on the Normal template from the pls_include_1 library, you will see the following:

In the upper left corner of the screen, the project name is listed. Your logon name is
below that. At the top of the page, there are left and right navigation arrows that allow
you to go to previously visited pages.

These two arrows allow you to go back and forward one page in your navigation
history. To see the history of visited pages, click the small down arrow next to the right
arrow. This displays a listing of visited pages (the current page is checked). To jump to
a page in this list, click it in the menu.

Just beneath the left and right arrows is the alarm banner. It lists the last five active
alarms.

Beneath the alarm banner is a tabbed-style menu. Its contents are determined by the
information entered in the Menu Configuration tool: Add Pages to Project Menu
Configuration on page 61. These tabs display in two rows:

• The upper row is typically used for organizing pages into several topics (or tabs). A
typical system would include topics for single lines, alarms/events, analysis (for
trends), and system supervision (allows you to view the network connection topics).

• The lower row lists the links/pages under the topic that is currently selected in the
upper row. If you select the single lines topic on the upper row, the lower row
displays all of the links to individual single line pages.

If there are more links available than the ones that fit on the page, a small arrow
displays at the right hand side of the row. Click the arrow to display a pop-up menu of
the remaining links. Click a link in the menu to shift the contents of the row to make it
visible for selection.
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NOTE: When viewing the single lines: if the busbars and circuit breakers do not display
as expected, it could be that a custom genie is not set up correctly. See Create New
Genies for details on customizing genies.
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Troubleshooting
This section contains hints and instructions for correcting issues with your project.

• CSV file format errors: see One-Line Errors and Warnings on page 48
• Use the One-Line Configuration Utility to repair problems with equipment on

graphics pages: see Perform Repairs for One-Lines on page 49
• General troubleshooting questions: see Frequently Asked Questions (FAQs) on

page 120

Frequently Asked Questions (FAQs)
The following items provide information about topics that generate frequent questions.

If I don't use PowerLogic drivers, how do I create device profiles?
The easiest way to do this is to:

Create a device type using a non-PowerLogic driver (like MODNET).

1. Using that device type, create a device profile.

2. You need to change the addressing of the new device type. The easiest way to do
this is to copy the addressing from a known device type, and then make the
necessary changes for the new device type.

How should we manage categories and subcategories?
We recommend that each integration team decide in advance which categories and
subcategories they will use. The I/O Device Managere requires the entire Profile name
(which uses the category and subcategory as part of its name). Thus, you must be
consistent in naming if the profiles are going to be shared and re-used.

1. Category should be used for a vendor.
2. Subcategory should be used to describe a type of device.

3. From the master computer that has the Profile Editor installed, create the categories
and subcategories that you plan to use.

4. Copy the DeviceTypeCategories.xml file (located in the OS-specific data directory:
Data/Profile Editor/ Vx.x ) to every computer being used to create profiles.

When should I create a device type rather than device profile?
Create a new device type, instead of a profile, when the addressing for a specific tag
needs to change. An example:

The integration team can choose which Input to which they will wire circuit breaker
status and position. In this case, the tags for circuit breaker status and position would
have different addressing, based on how that particular circuit breaker is wired. We
recommend a new device type in this case.

How do we synchronize a new PC with the master Profile Editor PC?
To synchronize a new machine with the latest device types and profiles from your
master Profile Editor PC, you can:

• Use the Import feature to import tags, device types, and profiles from either an
existing project or from SCL files. See Importing Files into the Profile Editor for full
details.
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• On the source PC: From the OS-specific Data/Profile Editor/ Vx.x directory, copy the
entire OS-specific Data/Profile Editor/ Vx.x directory to the corresponding directory
on the destination machine.

What do I do before I add or remove devices in the I/O Device Manager?
1. You must close all open dbf files in the Project Editor (or in Excel).
2. If you are removing a device, check “pack database after removal” on the last page

of the wizard.

3. Any changes that you made inside the Citect Project Editor (such as setpoints or
data type modifications) are lost when you delete the device from PowerSCADA
Expert.

What are the requirements for device names?
Device Name:

Keep Device name ≤ 16 characters. Use _ as a separator.

If you use a naming convention that incorporates location, you will be able to do
filtering on alarm location.

• For example, Site_Building_Panel_device would be named Sx_Bx_Px_Device.
(Site1_Building1_Panel1_CM41 — S1_B1_P1_CM41).

• The fewer levels you have, the more characters you can have in each level.

Device Comment:

Use this field for an alias of the device name.

This comment will be placed in the Equipment database, which is accessible from
Cicode.

How do I troubleshoot device communications issues?
PowerSCADA Expert drivers provide default communication settings that work with
most devices. However, in cases when communication losses occur, use this checklist
for finding the issues.

1. Initial checks, if the device is attached via a gateway:
— Ensure that all communication settings are correct on the gateway and device.
— Check the gateway timeout. A setting that is too low will cause many timeouts to

occur. A setting that is too high will impact performance. We recommend a 3
second timeout, because most devices work well with this setting. Some
devices may require a higher timeout (5 seconds).

2. In all communication setups (also see the driver help for parameters):
— Ensure that the PowerSCADA Expert driver timeout is correct. We recommend

that you set this to:
gateway timeout x number of clients + padding
Example: If the gateway timeout is 3 seconds and there are 3 clients, set the
timeout in PowerSCADA Expert to 10 seconds.

— Check the maximum block read size. Some devices do not handle large block
reads well. When you lower the maximum block read size, the requests are
smaller and faster. The downside is that more requests will be sent to the
device, and tags will refresh more slowly.

— Check the device to see if there are registers that it cannot read. Some devices
do not allow access to all registers.
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Example: Data is in register 100-125 and 130-150. PowerSCADA Expert will
perform one read from 100-150. If 126-129 do not allow reading, this packet will
return an exception. Use the appropriate logic code to mark these registers as
invalid reads.

— If there are still timeout/no response issues, enable retries on exception. Some
devices may not respond if they are performing other functions. In this case,
a0x0A or 0x0B exception will be returned to PowerSCADA Expert, which will
cause a communication loss. Enabling the "retry on exception" will re-try the
request.

How do I use MODBUS communications methods?
MODBUS TCP/IP via Gateway: Use this for any device that is not speaking TCP/IP
natively. These devices connect through a gateway device such as an EGX or ECC.

MODBUS TCPIP: Use this for any device that can speak TCP/IP natively. This includes
CM4 or PM8 devices that have an ECC card installed.

How can I add more than one device at a time?
The I/O Device Managere requires that the profiles have already been exported from
the Profile Editor to the project.

If the automation spreadsheet attempts to add a device that is already present in the
project, an error will be thrown.

In the event that an error is thrown (for invalid profiles, communication parameters,
etc), the row containing the error will display in Excel. To prevent duplicate device
entries from being attempted, you must remove any rows above the row indicated
in the error message.

If you need to keep a record of the devices added to the system, then keep each of the
spreadsheets that was used to install devices in a known location for that customer.

The Setup Sheet needs to be modified for each project. Specify the entire path for each
file.

The Input Sheet requires the following:

The entire path name for each profile. The path name for a profile is based on the
category and subcategory from the Profile editor.

Example: Schneider Electric.Monitoring Device.Branch Circuit Monitor Full

What are the naming conventions for servers and clusters?
There is no enforced naming convention for server and cluster names, other than the
restriction that each server name and cluster name must be unique. Cluster names
must be a maximum of 16 characters, no spaces; they may not begin with a number.

Each team should come up with a naming convention for the servers and clusters. If
the team is consistent, it will make it easier to edit/create the automation spreadsheet
used for device addition.

How and when do I create users for the Runtime environment?
New projects do not have any users created by default.

The default graphics objects (such as circuit breakers and alarm pages) are
constructed using a pre-defined set of user privileges the security grid). During
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development, you must have users of various privilege levels for testing purposes.
Create users for each of the various levels according to the security grid. To make the
best use of these privileges, we recommend that you use this security grid when
adding users as you create new projects.

See Default User Access Settings (Privileges) on page 57. For additional information,
see Using Security in the citectSCADA.chm help file (Program Files> Schneider
Electric > PowerSCADA Expert > v8.1 > bin).

How do I manage projects in the Citect Explorer environment of PowerSCADA
Expert?

Although the designer may wish to organise each project in a particular way to suit
customer's needs, the following is a recommended best practice:

1. Keep original ‘Master’ copies of the PLS_Example and the PLS_Include projects
for reference.

2. The Services group may develop a group-wide “include” project that will act as a
conduit between the PLS_Include project and all customer projects (e.g., "Group_
Include"). This will make the upgrading of PLS_Include much easier, as it will be
the only project that must be modified to be compatible with the new version in the
group-wide include project.

Any changes made to the PLS_Include project should be made at the Group_
Include project level. This would involve removing portions of the code from the
PLS_Include project, modifying the code and saving it in the Group_Include project.
By removing (or commenting out) the original code and placing the new code in the
Group_Include project, a layer of abstraction is preserved, further simplifying the
upgrade process. In other words, the only changes to PLS_Include should be code
removal.

3. When a new customer project is started, also create a customer-level “include”
project.

Always back up and restore the customer project and its associated include
projects together.

Always restore include project(s) before restoring the customer (or top-level)
project.

4. Upgrading PLS_Include:

Document all changes to PLS_Include. This is absolutely necessary when
upgrading to a new version of the PLS_Include project.

Minimize changes to the PLS_include project.

Abstract as many changes to the PLS_Include project as possible. This should be
accomplished by the use of multiple include projects as shown in the diagram
above.

New versions of PLS_Include will include a detailed description of each change,
allowing you to merge the old and new versions.

New versions of PLS_Include will maintain backward compatibility where possible.

On the Graphics page, what do I need to know about creating genies?
1. Creating a new genie:

The easiest way to create a new genie is to use an existing genie from the library.
This ensures that the new genie is compatible with the system, and that it preserves
this feature:
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— A sizing guide (a dotted rectangle) is included; it displays during graphics edit
mode. This guide ensures that new genies can be swapped with existing
genies without the need to recreate portions of the drawing. Save the new genie
in the appropriate project (do not overwrite the provided genies).

Save the new genie in the appropriate project (do not overwrite the provided
genies).

2. Copying a genie to another project:

Open the genie in the graphics editor, and do a <save as> into another
project/library.

3. Genie Form Files:

Any new genie (copied or created) will not have a .frm file entry associated with it.
While the new genie is functional, it will show a cryptic unformatted properties box
in the Graphics Editor. You can create your own .frm file with the needed entries by
following the instructions available in the Citect Knowledge base.

If you want to use the .frm dialog box that belongs to the genie you copied, go to the
PLS_Include library; locate the .ctm and .ftm files. Each library has its own .ctm/.ftm
files that include the description for every genie in the library. (This is an ascii text
file that you can open in any text editor.) Find the genie that you copied (or on
which you're basing the new form). Copy the portion that matches the copied genie,
and create a .frm file that has the desired library name on it. Copy in the text from
the .frm file. Restart Citect Explorer or it will not detect the new .frm.

4. Genie Sizing

The provided genies come in two sizes: size 1 and size 2. When making a new
genie for reuse among multiple projects, it will be beneficial to create a genie for
both sizes. Follow the same steps for both sizes (sizing guides are provided for
both sizes).

How do we customize existing templates?
Template Editing:

All objects on the page contain one or more Animation Numbers (ANs). Symbols take
one AN while genies may take tens to hundreds of ANs. Placeholder ANs allow you to
add objects to a template that is used on existing pages.

Some default templates contain ANs that have associated Cicode functions that rely on
the animation number to remain a fixed number. For this reason, we have pre-
allocated a set of ANs for the default templates. The base normal template uses ANs
1–263, and it has placeholder ANs from 264–500. When customizing this template,
you should use the placeholder ANs as required.

You can place an AN (or a placeholder AN) on the page by using the “System 3.x/4.x
tools available in the Graphics Builder under Tools< Options.

The default template uses ANs 1–263 and it has placeholder ANs from 264–500.

New objects added to a page or template will take the next available ANs. Any
previously used (and now abandoned) ANs will be reused.

To add an object on the template, you must:

1. Open the template.
2. View the page properties and change the page width to 2000. This will reveal the

hidden placeholder ANs on the page. You may have to change the width to a wider
dimension for widescreen templates.
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3. Determine how many ANs the new object requires. (You can place the new object
on a blank page and then view the object in the object browser.)

4. Remove exactly the amount of ANs to allow the new object to be placed on the
template. Remove ANs beginning with the lowest available placeholder AN (in the
default template, this would be 264).

5. Place the object on the template.

6. Save the template.

7. Create a new page based on this template.

8. Drop a numeric object on the page.

a. This object’s AN should be 502 (501 is reserved for placing the template on the
page).

b. If the object has an AN less than 502 then you have unused AN(s) on the
template. This must be resolved. (Place additional ANs on the template to rectify
this situation.)

c. If the object has an AN greater than 502 then you have too many ANs on the
template (a AN on the template is going beyond the 500 limit). You must find the
culprit (via the object browser) and rectify the situation using the steps above.

How do I change the default pickup/dropout text for alarms?
The default ‘pickup/dropout’ text is shown as Appearance/Disappearance.

To change globally:

This text may be changed by configuring INI parameters in the citect.ini file. For
more information, see the PowerSCADA Expert System Integrator’s Manual
(Grahics Library Parameters)

This is the global fallback text that will be used in the event that pickup/dropout text
is not specific on a per-alarm basis in the Device Profile. You can specify the per-
alarm pickup/drop-out text on the profile tab in the Profile Editor.

To change on an individual basis:

See the PowerSCADA Expert System Integrator’s Manual (Viewing Device Profles:
"Alarm On Text" and "Alarm Off Text").

What can I modify during runtime?
Set-point Configuration during runtime: In the Alarm Server entry in the project editor,
view the advanced properties (F2) and set publish alarm properties = TRUE

Events Accessible at runtime: By default, 5000 events are accessible (view, filter,
print) during runtime. Additional events are logged to disk. The number of events
accessible at runtime may be changed by the [Alarm] SummaryLength parameter in
the INI file.

Why do the browser navigation buttons not work?
If the browser navigation buttons do not work when you are viewing the runtime
window, you have probably added a new page, but have not done the following:

• added the startup page to the Page parameter. See Setting a New Page as the
Project Startup Page for help.

• left the INI settings at <default>. In the Computer Setup Wizard, General Options
Setup screen, do not change the StartupPage field; leave it as <default>.
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What can I set up in logging and archiving?
Event Logging and Archiving:

Event fields that are logged to disk may be configured by adjusting the AlarmFormat
parameter.

There is no automatic maintenance performed on the log files. It is important that the
log/waveform data be cleared out periodically (to prevent the hard drive from filling up;
this does not affect performance).

How do I create and configure busbars?
When drawing one-line diagrams:

Analyse the drawings at a customer site.

Number the busbars consistently on the one line diagram(s). If busbar 14 spans
across multiple pages, it should be numbered busbar 14 on all pages. Label the
voltage level (0–3) on each busbar.

Uses for Line Active:

Page Connections: Many one-line diagrams will span multiple pages. To connect
these pages together, you must use the line active field of the ‘incomers’ of the
second and subsequent pages. Set the line active field of the incoming busbars on
these pages to an expression that references the nearest device on the same
busbar of the previous page.

Metered Busbar: Many busbars are actually metered. It is more accurate to allow
these metering devices to dictate state than to rely solely on the simulation (see
Expressions below).

Configuration of Line Active:

Simulation: If the Line-Active field is left blank, the busbar state will be determined
by surrounding devices.

Expressions:

A Cicode expression in the form of Device\Tag > Nominal Voltage (I.E., S1_B1_P1_
CM41\MMXU1\PhV\zavg > 120).

If the expression is TRUE, the ACTIVE color will be shown. The active color is
determined by the voltage level assigned.

If the expression is FALSE, the DE-ENERGIZED color will be shown.

Hard-Coded:

If no upstream devices are available (in the event of an incomer, for example), you
may have no other choice than to ‘hard code’ this field to a ‘1’. This forces the
busbar to always be ACTIVE.

What INI parameters should I use for debugging?
We recommend that you contact Technical Support before performing any debugging.

Parameter: [PowerLogicCore]
DebugCategory = All

DebugLevel = All (or Error)

LogFileArchive = Deprecated; no longer used. Use [Debug]SysLogArchive instead.
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LogFileSize = Deprecated; no longer used. Use [Debug]SysLogSize instead.

Parameter Details:

DebugCategory defines which message categories to log. (See table below).

DebugLevel defines debug levels of messages to be logged. (See table below).

Debug Levels

The following debug levels are accepted by PowerLogic driver core library:

WARN: log all warning level messages

ERROR: log all error messages

TRACE: log all trace messages

DEBUG: log all debug messages

ALL: include all level messages

Debug Categories

PowerLogic core library and drivers messages are grouped in categories. Each of
these categories can be enabled independently from others in any combination.

MISC: miscellaneous messages that do not all into any other category

ALARM: messages related to alarms, regarding collection and detection

WAVE: messages related to waveforms -- waveforms download, processing

REAL: messages related to real-time data collection

STATE: messages related to internal object-state changes

CORE: core events that do not fall into driver-specific logic

MODBUS: TCP/MODBUS messages

ENTRY: trace messages produced when driver API entry points are called

PORT: traces related to the port events

UNIT: traces related to specific unit events

WAVETOALARM: not used

DATAPOINT: debug messages related to data points

STATISTICS: enables driver statistics data output

COMMAND: messages related to commands

REPLICATION: messages produced by replication subsystem

ALL: enables all categories

Parameter: [Debug]
Menu = 1

Parameter Details:

The Menu parameter determines whether the Kernel option is displayed on the control
menu of the runtime menu. This can also be enabled using the Computer Setup Editor.

How do I tune my system for best performance?
There are several parameters that you can use to enhance your system's performance:

Driver-tuning parameters:

Parameter (Back Polling Rate): [SEPAM40]

CacheRefreshTime = 1000
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InitUniCheckTime = 120

Retry = 3

Timeout = 1000

Parameter Details:

The CacheRefreshTime parameter controls the maximum rate at which the driver
will attempt to repopulate its cache. If the driver cannot refresh its cache within the
time period specified, it will collect data as fast as the network allows.

This back polling rate can be global to all devices or tuned up to a specific I/O
device.

The InitUniCheckTime parameter controls how long the driver will wait before
attempting to bring a device online after it has gone offline. This value can be
decreased to bring offline devices back into service in a shorter period of time. In a
multi-drop scenario, this time should be relatively long, to prevent init unit requests
from stalling communications to the rest of the devices on that port.

The Retry parameter defines the number of retry attempts for specific MODBUS
requests. Retries will only occur in response to the MODBUS errors which are
defined below.

The Timeout parameter controls how long the driver will wait for a response from a
device before setting that device as offline. This value should be greater than the
device/gateway timeout period.

Parameter: [Device]
WatchTime = 5000

Parameter Details:

Device WatchTime is the frequency that PowerSCADA Expert checks devices for
history files and flushes logging data to disk.

Default: 5000

Range: 1000–3600000 milliseconds.

Miscellaneous Parameters

Parameter: [Kernel]
Task = 20000

Parameter Details:

Kernel Task is the number of tasks. Increasing the number of kernel tasks is used
when “Out of Kernel Task” message is received. The change will be likely for large
systems.

Default Value: 256

Range: 50–32767

Parameter: [Page]
ScanTime = 250

Parameter Details:

Page ScanTime determines how often the Animator refreshes a graphics page at
runtime.

Default: 250

Range: 1–60000 milliseconds
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Parameter: [ALARM]
ScanTime = 500

Parameter Details:

Alarm ScanTime determines the rate at which alarms are scanned and processed.

Default: 500

Range: 0–60000 milliseconds

If a tag is configured, how is it polled in the device?
In other words, is a tag only polled on demand when it is requested by a client (for
example, when the operator displays a page with the tag on it)? Or are all configured
tags polled all of the time, with the relative polling rates/communications bandwidth
carefully managed?

The ModNet driver polls real-time tags on a user demand basis (when a user opens a
page with the tags on it). Therefore, the time to retrieve data will vary, depending not
only on the communications bandwidth, but on the amount of data being requested.
This can vary significantly, depending on which pages are displayed by the operators
at any particular time.

The PWRMODBUS driver polls all configured tags; however, different types of tags can
be polled at different relative rates, and the available communications bandwidth is
carefully managed. This approach means that tag update rates are not subject to the
scalability issues associated with operator actions (as is the case for the ModNet
driver). It is also advantageous in that performance issues associated with
communications bandwidth or IODevice response times can be determined at
SAT/time of implementation and are not subject to significant change during operation.

The different tag types can be allocated relative importance in data requests,
expressed as a percentage. (See Bandwidth Allocation Parameters in Performance
Tuning Parameters, in the PowerSCADA Expert System Integrators Manual.) Keep in
mind that any unused bandwidth allocation (from, for example, events retrieval) is
made available for other data types to use. If the event does not need the default 25%
allocation, it will be made available to the other parameters (real-time tag retrieval, etc).
This potentially increases the update rate of real-time tags.

Additionally, the real-time tag relative scan rate based on priority can be set to three
different levels. (See "Tag Scan Rate Parameters" in Permance Tuning Parmeters, in
the POwerSCADA Expert System Integrators Manual) This means that, if some real-
time tags are more important that others, you can set their relative priorities. For
example, configuration tags vs. important real-time tags vs. normal real-time tags.

Device popup from a one-line: Why do the fields overlap?
This is controlled by a parameter entry:

Section: Page

Name: EquipDetailDescLength (the total number of characters in a single row of this
popup)

Default = 48. The problem will occur with a larger font or if the window is resized. The
default value of 48 can be changed or the window and associated genies can be
resized.
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Can I change the %CLUSTER% name in the I/O Device Manager?
No. If you change the placeholder %CLUSTER% to any other name in the I/O Device
Manager, the system will be unable to find the actual cluster to which it refers.

A device can prevent writes to its registers: how do I ensure that writes are suc-
cessful?

PowerSCADA Expert cannot provide feedback about whether a write to a device
register is successful. If a device is capable is preventing (blocking) writes to its
registers (for example, Sepam), you need to verify that its “block” feature is not
enabled. Do this at the device.

NOTE: In Cicode, you can also use the tagwrite function in blocking mode, i.e., bSync
parameter = true; Check the return code: 0 = success, anything else = error. For more
information, see the Cicode Programming Reference help file.

How do I prevent PowerSCADA Expert from accidentally making invalid areas in
memory available to reads and writes?

PowerSCADA Expert normally optimises its packets for greatest performance. This
optimisation can sometimes includes invalid areas of memory in devices. These invalid
areas can be specifically defined and excluded from optimisation packets created by
PowerSCADA Expert. For more information, see "Advanced Tage Blocking
Capabilities" in Performance Tuning Parameters, in the PowerSCADA Expert System
Integrators Manual.

How do I create an audit in the Event Log for user logins and logouts?
//LOGOUT

FUNCTION

PLSLoginUser()
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//INT iPage = PageInfo(1);

INT iPage = WinNumber();

IF mbLoginFormShown[iPage] = TRUE THEN

RETURN; //form already shown

END

//prevent multiple forms

mbLoginFormShown[iPage] = TRUE;

IF (UserInfo(0) <> "0") THEN

// Confirm User Action

IF (0 = Message(StrToLocalText("@(Confirm)"), StrToLocalText("@
(Logout)"), 1+32)) THEN

PLSAlmDspEventAdd(0, 0, 1, "User Logout", Name(), "Logout", "");

Logout();

END

mbLoginFormShown[iPage] = FALSE;

RETURN;

END

IF (0 = LoginForm())

PLSAlmDspEventAdd(0, 0, 1, "User Login", Name(), "Login", "");

END

mbLoginFormShown[iPage] = FALSE;

END

Why am I seeing #COM for circuit breaker status in the genie status page?
If this is a Micrologic P device, and it does not have a CCM, you will not be able to view
data referring to circuit breaker status, e.g. racked in/racked out. When there is no
CCM, the device profile should not have tags that refer to the CCM.

Why can't I acquire waveforms in the waveform viewer?
The "acquire" feature (the "A" button on the waveform viewer) does not work in
PowerSCADA Expert. You can, however, view waveforms from device onboard
waveform files. To do this:

• At the device or in the meter configuration software, add the appropriate alarm, and
enable automatic capture of the waveform when the alarm occurs.

• In the Profile Editor (Create Device Profiles tab), check the Waveform box for the
alarm you added.

• When the alarm occurs, the waveform is captured. You can view the waveform in
the Alarm Log. You can also view alarms/waveforms from a drawing in the runtime
environment. Click the genie for the device; right-click the alarm to view the
waveform.

Note that, in very large systems, it could take as much as an hour for the waveform
to appear.
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Why won't the Excel DBF Add-In toolbar install?
When you are installing the Excel DBF Add-In toolbar, you may see this error: "Error
1308. Source file not found....."

You can click "ignore" at this error, and the install will finish. The next time you open
Excel, the DBF toolbar will display.

What causes the "First dbf record" error message? How do I keep it from hap-
pening?

The error message "First dbf record" tells you that a project is not found. This happens
when you add a project, and then rename it or delete it. Then, when you try to create a
new project, you see this error message.

To resolve this issue, simply shut down and then restart the Citect Explorer.

Why is my device in comms loss?
When you bring your system on line, and you find that PowerSCADA Expert has lost
communications with a device, check the following:

• Verify that the physical correction is correct and secure.
• Verify the IP address.
• Verify the Modbus address.
• Check the statusRegister, statusRegistersCount, and statusRegisterType (see for

details)

How do I set up select before operate?
For systems in which you can determine that a single user is selecting a device prior to
sending an open/close command, you can add a "select before operate" button.

To do this:

1. Locate the Select Before Operate tag in the variable tags.
2. Append \str to the end of the tag name.

3. Change the data type to STRING.

4. Click Add.

This creates the SBOw tag for the IEC 61850 advanced control screen. For more
information about advanced control, see "Set Up IEC 61850 Advanced Control" in the
PowerSCADA Expert System Integrators Manual.
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Diagnostics
Logging Level:

This feature turns on extra diagnostic information that can be useful when diagnosing
problems that occur in application services or its hosted applications (such as
LiveView). Choose the level of logging to be used in all applications. Debug and
Verbose increase the amount of information that is logged during runtime for
applications such as Basic Reports and LiveView.

• Normal: Use when the project is live.
• Debug: includes additional logging statements (in the Windows event log named

PowerLogic). This logging should not affect performance in the system during
runtime.

• Verbose: releases additional diagnostic information, such as large lists, that could
affect system performance.

Service Inventory:

This is a read-only list of web services hosted by the Schneider Electric
CoreServiceHost, details about them, and whether they are running.
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